Du må være registrert og logget inn for å kunne legge ut innlegg på freak.no
X
LOGG INN
... eller du kan registrere deg nå
Dette nettstedet er avhengig av annonseinntekter for å holde driften og videre utvikling igang. Vi liker ikke reklame heller, men alternativene er ikke mange. Vær snill å vurder å slå av annonseblokkering, eller å abonnere på en reklamefri utgave av nettstedet.
  20 1029
Heisann!

Jeg har nettopp installert Apache og PHP på min Linux maskin.

Installeringen gikk fint, og jeg fikk ingen feilmeldinger.
Først prøvde jeg å gå inn på localhost for å sjekke om det fungerte, og jeg kom inn på "It works" siden.
Etter det prøvde jeg å gå inn på ip'en min. Det virket ikke.

Dette er siden jeg kom inn på da: (Trykk for større bilde)

PS: Det står freak.no i adressebaren fordi jeg skrev det der for å skjule IP.


Vet noen hvorfor jeg ikke kommer inn på It works siden?

Kanskje jeg bruker feil IP? Jeg fikk IP'en min fra Whats My IP.

Takker for all hjelp!
Om jeg ikke tar helt feil, er det fordi multimodemet ditt fra din ISP loopbacker WAN IPen din til 127.0.0.1 (som da blir modemet sin IP) og det vil dermed routes inn på modemet i stedenfor videre inn i nettverket ditt. Sist jeg pusla med det (samma type modem, NGT) så fant jeg ut at jeg måtte inn via telnet inn på modemet for så å fjerne denne loopbacken, noe jeg ikke gadd å styre med. Etter at jeg fikk CD var det bare tut og kjør med port forwarding inn på lokal NAT IP.

Prøv å få noen utenifra nettverket ditt til å gå inn på din WAN IP og se hvor de havner.

Skal ikke si at jeg har 100% rett, men var det jeg konkluderte med sist jeg knota med det.
Du er nødt til å fjerne loopback som Gisse sier. I tillegg må port 80 forwardes til maskinen med Apache.
Otaku
onClipEvent's Avatar
Trådstarter
Er det mulighet for å fjerne loopbacken på den siden som er screen shota' over her?

Er ikke 127.0.0.1 det samme som localhost?
Joda, 127.0.0.1 er localhost - men siden første ledd i nettverkskoblingen utenifra og inn hos deg er multimodemet, og routingen skjer på multimodemet, så er det også naturlig at 127.0.0.1 (localhost) for multimodemet er - nettop seg selv, multimodemet. Dette er noe som er lagt inn på noen multimodem (også kjent som routere) som man får fra ISPen sin. Har ikke så mye erfaring med det, men den lille erfaringen jeg har med NGT er at de har lagt inn denne "funksjonen". Hvis du ringer inn til NGT kan det også hende at de kan hjelpe deg med å fjerne denne funksjonen.
Otaku
onClipEvent's Avatar
Trådstarter
okei. Kan dette ha noe med brannmuren å gjøre? Brannmuren er satt til å droppe innkommende og tillate utgående.
Jeg må rette meg selv, man skal enable loopback, ikke fjerne.

Natloopback er satt til disabled som standard i Speedtouch-routere og er ikke en innstilling satt av NGT. NGT leverer forøvrig ikke Speedtouch 780 heller, så det vil ikke være noen hensikt i å ringe NGT. Dette blir litt utenfor supportområdet til de fleste ISPer med mindre du betaler for en tjeneste som skal gi deg mulighet til å sette opp webserver hjemme.

Det er ikke akkurat vanskelig å ordne det selv. Et raskt googlesøk finner nok mange guider for oppsett av egen webserver bak en Speedtouch.

Iallefall, for å skru på loopback i Telnet:
ip config natloopback=enabled
saveall
Otaku
onClipEvent's Avatar
Trådstarter
danielsk: Jeg bruker ikke Windows, så det hjalp ikke stort. Det med NAT loopback er sikkert riktig though. Er bare litt vanskelig å finne ut med linux.
Sitat av onClipEvent Vis innlegg
danielsk: Jeg bruker ikke Windows, så det hjalp ikke stort. Det med NAT loopback er sikkert riktig though. Er bare litt vanskelig å finne ut med linux.
Vis hele sitatet...
Bare Telnet routeren og legg inn kommandoen du.
Otaku
onClipEvent's Avatar
Trådstarter
Okei. Jeg kom meg inn på routeren via telnet og skrev inn komandoen.

{admin}=>ip config natloopback=enabled
{admin}=>saveall
{admin}=>

Ingen feilmeldinger, men jeg kommer fortsatt inn på speedtouch. Se om dere kommer inn på ip'en: http://85.167.173.250

PS: Måtte reboote, så prøv på nytt hvis dere har prøvd..
Nei, man kommer ikke inn.

Jeg har sittet og knotet med apache2 på ubuntumaskin selv halve kvelden, men jeg hadde ikke akkurat dette problemet....
Otaku
onClipEvent's Avatar
Trådstarter
Da tror jeg at jeg gir opp.. Jeg klarte å fu**e internette mitt når jeg drev å tukla med dette, så jeg tror ikke jeg tør å prøve mer

Takk for all hjelp!
Tom for megabytes
AtXbYeA's Avatar
Sånn som jeg leser det i din første post er det ikke 127.0.0.1 du prøver å nå orginalt, du prøver å nå den offesielle IP'en din ?
Mao f.eks 84.21.42.53 etc ?

Og du havner deretter inn på modemet ditt, noe som betyr at modemet svarer på port 80 by default, noe som er skummelt i seg selv.
Det hadde vært interessant å fått IP'en du skrev inn for å se om den svarer for oss på utsiden også..
Da er isåfall løsningen å få skrudd av web-serveren på WAN'et og forwarded port 80 til webserveren din internt.

Forøvrig dersom du bare skal nå ting internt er det greit å editere hosts-filen.

F.eks hadde jeg eirikz.com tidligere mot min webserver, utenifra ser siden helt fin ut, men pga dependancies i multi-site apache så ikke siden riktig ut når jeg gikk inn fra lokalnettet på bare IP, masse bilder manglet o.l.
Det ble fort løst ved å legge til :
192.168.1.199 eirikz.com
i hostsfilen som førte til at hver gang jeg slo opp eirikz.com i browseren min lokalt ville jeg møte den lokale interne adressen, men samtidig forespørre de samme filene og bildene.
Otaku
onClipEvent's Avatar
Trådstarter
IP: 85.167.173.250

Det er mange som har prøvd å gå inn, men siden bare timeout'er. Nå gjør den det på meg også. Jeg kommer ikke inn på modemet lenger, så jeg må gå inn på modemet via 10.0.0.138.

Jeg har nok ødelagt noe tror jeg..
Tom for megabytes
AtXbYeA's Avatar
Svarer iallefall ikke på port 80 ;-)

Men du har faktisk sikret nettet ditt, dersom det fungerte før, noe som er bra.

Nå burde du heller se på den faktisk problemstillingen din, å få svar fra riktig host eksternt eller internt fra når du bruker den faktisk adressen og ikke loopbackadressen.
Otaku
onClipEvent's Avatar
Trådstarter
Problemet er at jeg ikke forstår halvparten av det dere snakker om

Hvis noen kunne forklart litt nærmere, så hadde det vært supert!
Har du forwarda port 80 til serveren? Hvis ikke;
Gå in på modemet ---> Toolbox ---->Game & application sharing ----> Assign a game or application to a local network device (helt nederst på siden) ---> Så velger du http (TCP:80) fra dropdown menyen til venstre på menyen til høyre velger du navnet på servern (evt. taster inn den lokale ipen).
Otaku
onClipEvent's Avatar
Trådstarter
Litt dumt, men er den lokale ip'en f.eks: 10.0.0.1 ?

Jeg har prøvd å gjøre det der, men jeg valgte navnet på pc'en min (petter), og det eneste som skjer da er at siden timer ut.
Sitat av onClipEvent Vis innlegg
Litt dumt, men er den lokale ip'en f.eks: 10.0.0.1 ?
Vis hele sitatet...
Det stemmer.
Otaku
onClipEvent's Avatar
Trådstarter
Nå har pc'en skifta ip
Nå er den 85.167.44.19

Jeg kommer fortsatt ikke inn. Selv etter at jeg gjorde det du sa at jeg skulle gjøre.
Jeg har ikkje noen port scanner for hånden, så for ikkje sjekket, men er ganske sikker på at det er apache serveren din som er feilen, apache har en god del innstillinger på hvem som kan besøke siden... o.l.

Hvis noen har en port scanner så kunne dere jo scannet IPen hans, å sett om port 80 var åpen.
Moderer