Du må være registrert og logget inn for å kunne legge ut innlegg på freak.no
X
LOGG INN
... eller du kan registrere deg nå
Dette nettstedet er avhengig av annonseinntekter for å holde driften og videre utvikling igang. Vi liker ikke reklame heller, men alternativene er ikke mange. Vær snill å vurder å slå av annonseblokkering, eller å abonnere på en reklamefri utgave av nettstedet.
  285 37062
Noen som har fått dette til å fungere med pfSense? Har lagt inn static route til 10.133.0.0/16, på akkurat samme vis som den gamle 172.21.0.0/16, men gjør ingen forskjell. Det er for øvrig ikke mulig å legge inn noe next hop, men det fungerte jo før mot 172.21.0.0.
Sitat av BillyIdle Vis innlegg
Noen som har fått dette til å fungere med pfSense? Har lagt inn static route til 10.133.0.0/16, på akkurat samme vis som den gamle 172.21.0.0/16, men gjør ingen forskjell. Det er for øvrig ikke mulig å legge inn noe next hop, men det fungerte jo før mot 172.21.0.0.
Vis hele sitatet...
Du må ha med begge rutene, du må ikke erstatte den gamle med den nye.
Sitat av KydeX Vis innlegg
Du må ha med begge rutene, du må ikke erstatte den gamle med den nye.
Vis hele sitatet...
Nei, det har jeg ikke gjort. La inn den nye på samme vis som den gamle. Har begge.
Sitat av ozzy00 Vis innlegg
Så forsøk i brannmur fra dekoder mot addresse 10.133.19.200 og 10.133.20.200, og antok at dette var forsøk på å nå interne adresser hos altibox.
Vis hele sitatet...
Har du Mikrotik ruter? Hvordan finner jeg brannmurlogg der? Peiling? :
Merkelig at det ikke fungerer her. Ut fra følgende traceroute så ser det jo tilsynelatende ut til at det fungerer, selv om jeg ikke kommer helt frem (kan jo være at 10.133.20.200 ikke svarer på ping):

Kode

> traceroute -n 10.133.20.200
traceroute to 10.133.20.200 (10.133.20.200), 30 hops max, 60 byte packets
 1  10.0.0.1  2.586 ms  3.102 ms  3.286 ms
 2  10.173.236.1  5.446 ms  6.224 ms  6.530 ms
 3  10.162.34.43  7.056 ms 10.162.34.40  8.440 ms  8.683 ms
 4  10.162.34.44  9.071 ms 10.162.34.38  9.063 ms 10.162.34.44  10.197 ms
 5  10.162.128.4  12.242 ms  12.447 ms 10.162.128.9  13.210 ms
 6  10.162.30.2  14.333 ms  11.349 ms 10.162.36.3  13.286 ms
 7  10.162.128.16  19.407 ms  17.155 ms  16.412 ms
 8  10.162.31.254  13.140 ms 10.162.35.254  12.190 ms 10.162.36.0  14.108 ms
 9  213.167.114.160  33.128 ms  34.141 ms  34.398 ms
10  10.1.16.5  34.088 ms  31.424 ms  32.083 ms
11  * * *
[...]
30  * * *
Noen andre som har fått det til å fungere som kunne tatt en traceroute og sett om de får samme resultat?



EDIT:
Og der var mysteriet løst for min del! Har Altibox-tunerne mine i et separat VLAN for å slippe at de ser resten av nettet mitt. Dermed har jeg en regel i brannmuren som blokkerer for all trafikk til andre lokale nett, inkludert 10.0.0.0/8
Sist endret av BillyIdle; 4. september 2020 kl. 16:27. Grunn: Automatisk sammenslåing med etterfølgende innlegg.
Sitat av BillyIdle Vis innlegg


EDIT:
Og der var mysteriet løst for min del! Har Altibox-tunerne mine i et separat VLAN for å slippe at de ser resten av nettet mitt. Dermed har jeg en regel i brannmuren som blokkerer for all trafikk til andre lokale nett, inkludert 10.0.0.0/8
Vis hele sitatet...
Jeg kjører bare dekoderne gjennom en switch som har igmp snooping. De ser annen trafikk, men det er kun dekoderne som får tv-trafikken.
Skjønner det, men har litt problemer med å stole på produkter fra Huawei
Noen som vet om dette setupet vil fungere?

1. Altibox FMG i Bridge Mode
2. Internett fra FMG til USG Pro 4
3. Internett videre fra USG Pro 4 til switch 1
4. TV direkte fra FMG til switch 1
5. Samle internett og TV i én utgående port på switch 1
6. Sende internett og TV i én ethernet kabel til switch 2
7. Splitte internett og TV i to utgående porter på switch 2

Tanken var å unngå avansert konfigurering, og håndtere dette utelukkende med vlans i Unifi Controller.

Innspill mottas med takk.
Hva er egentlig så galt med sentralen til altibox?
Hei!

Jeg forsøker å konfigurere IPTV fra Altibox. Jeg må innrømme at jeg er ganske nybegynner når det kommer til nettverk. Dog er det satt opp en Ubiquiti EdgeRouter X SFP, hvor internett fungerer.

Jeg har prøvd å legge til VLAN 101 (TV), men da stopper hele nettet å fungere.


Her er et bilde av hvordan det ser ut. Jeg måtte disable den foreløpig.

Noen som kan hjelpe meg å konfigurere dette?
Sist endret av Nozemi; 7. september 2020 kl. 04:39.
Sitat av roger45 Vis innlegg
Noen som vet om dette setupet vil fungere?

1. Altibox FMG i Bridge Mode
2. Internett fra FMG til USG Pro 4
3. Internett videre fra USG Pro 4 til switch 1
4. TV direkte fra FMG til switch 1
5. Samle internett og TV i én utgående port på switch 1
6. Sende internett og TV i én ethernet kabel til switch 2
7. Splitte internett og TV i to utgående porter på switch 2

Tanken var å unngå avansert konfigurering, og håndtere dette utelukkende med vlans i Unifi Controller.

Innspill mottas med takk.
Vis hele sitatet...
Det vil funke det. Jeg skjønner ikke hva du skal med alle switchene, men det har du vel en grunn for. Pass på at du bruker switcher som har IGMP snooping, da vil TV-trafikken gå kun til dekoderen som spør om det, og ikke streames ut på alle portene.

Sitat av kimzor Vis innlegg
Hva er egentlig så galt med sentralen til altibox?
Vis hele sitatet...
For min del, ingenting lenger. Da den nye TV-løsningen kom for to år siden, så kunne man ikke ha sentralen i bridgemode. Dersom man da skulle bruke egen ruter, så fikk man dobbel NAT, noe som er problematisk dersom man kjører egne tjenester bak brannmur. Derfor valgte jeg å fjerne hele sentralen til altibox. Nå, etter å ha gjort alt arbeidet, så synes jeg det oppsettet jeg har fungerer bedre til mitt bruk. Også kan jeg skippe en av boksene i oppsettet.

Sitat av KydeX Vis innlegg
Har du Mikrotik ruter? Hvordan finner jeg brannmurlogg der? Peiling? :
Vis hele sitatet...
Fant en måte selv. Man kan bruke Winbox til å se trafikken.
Sist endret av KydeX; 7. september 2020 kl. 08:42. Grunn: Automatisk sammenslåing med etterfølgende innlegg.
Sitat av Nozemi Vis innlegg
Hei!

Jeg forsøker å konfigurere IPTV fra Altibox. Jeg må innrømme at jeg er ganske nybegynner når det kommer til nettverk. Dog er det satt opp en Ubiquiti EdgeRouter X SFP, hvor internett fungerer.

Jeg har prøvd å legge til VLAN 101 (TV), men da stopper hele nettet å fungere.


Her er et bilde av hvordan det ser ut. Jeg måtte disable den foreløpig.

Noen som kan hjelpe meg å konfigurere dette?
Vis hele sitatet...

sjekk route tabellen, jeg tipper du har en default route via både vlan 102 og vlan 101?

(Du skal kun ha default route via vlan 102)
Har du en Unifi USG 4 Pro må du i tillegg til statisk rute også utvidde NAT reglene, lagde regel 5002 til formålet:

"service": {
"nat": {
"rule": {
"5000": {
"description": "MASQUERADE LAN TO WAN",
"log": "disable",
"outbound-interface": "eth2.102",
"protocol": "all",
"source": {
"address": "0.0.0.0/0"
},
"type": "masquerade"
},
"5001": {
"description": "MASQUERADE FOR TV WAN",
"destination": {
"address": "172.21.0.0/16"
},
"log": "disable",
"outbound-interface": "eth2.101",
"protocol": "all",
"type": "masquerade"
},
"5002": {
"description": "MASQUERADE FOR TV WAN_2",
"destination": {
"address": "10.133.0.0/16"
},
"log": "disable",
"outbound-interface": "eth2.101",
"protocol": "all",
"type": "masquerade"
}
}
}
}
Sitat av KydeX Vis innlegg
Det vil funke det. Jeg skjønner ikke hva du skal med alle switchene, men det har du vel en grunn for. Pass på at du bruker switcher som har IGMP snooping, da vil TV-trafikken gå kun til dekoderen som spør om det, og ikke streames ut på alle portene.
Vis hele sitatet...
Har to Unifi US‑8‑60W, de har vel IGMP snooping? Jeg må sende tv og internett opp flere etasjer og har bare én ethernet kabel tilgjengelig, så vidt jeg forstår er eneste mulighet å gjøre dette via flere switcher? Jeg kan selvfølgelig sende nettet opp trådløst, men det ønsker jeg ikke.

Sitat av KydeX Vis innlegg
For min del, ingenting lenger. Da den nye TV-løsningen kom for to år siden, så kunne man ikke ha sentralen i bridgemode. Dersom man da skulle bruke egen ruter, så fikk man dobbel NAT, noe som er problematisk dersom man kjører egne tjenester bak brannmur. Derfor valgte jeg å fjerne hele sentralen til altibox. Nå, etter å ha gjort alt arbeidet, så synes jeg det oppsettet jeg har fungerer bedre til mitt bruk. Også kan jeg skippe en av boksene i oppsettet.
Vis hele sitatet...
Gjelder dette også for min løsning, altså at det blir problemer med dobbel NAT?
Sitat av roger45 Vis innlegg
Har to Unifi US‑8‑60W, de har vel IGMP snooping? Jeg må sende tv og internett opp flere etasjer og har bare én ethernet kabel tilgjengelig, så vidt jeg forstår er eneste mulighet å gjøre dette via flere switcher? Jeg kan selvfølgelig sende nettet opp trådløst, men det ønsker jeg ikke.



Gjelder dette også for min løsning, altså at det blir problemer med dobbel NAT?
Vis hele sitatet...
Hei. Jeg kjører også tv og internett opp en etasje på samme kabel via switch, det er ikke noe problem. Som sagt så har Altibox fiksa den utfordringen de hadde, slik at nå kan du sette FMG i bromodus, så da får du ikke dobbel NAT.
Sist endret av KydeX; 10. september 2020 kl. 09:01.
Sitat av ozzy00 Vis innlegg
Så forsøk i brannmur fra dekoder mot addresse 10.133.19.200 og 10.133.20.200, og antok at dette var forsøk på å nå interne adresser hos altibox.
Vis hele sitatet...
Fikk endelig somlet meg til å legge inn

Kode

send vendor-class-identifier = "VMG8825-B50B";
i dhclient.conf slik at DHCP-serveren sender ruting-info på VLAN 101, som tipset av @Trrunde her: https://github.com/trrunde/routercon...uter-x-altibox


Og da ser jeg at Altibox ganske riktig har lagt til 10.133.0.0/16 siden sist jeg sjekket (i februar). Det er den eneste ruten som er endret.

Dette er nå det de tydeligvis ønsker rutet via VLAN101 hos meg (minus default, vil jeg tro).

Kode

    Option: (121) Classless Static Route
        Length: 123
         default-10.171.174.1
         10.133.0.0/16-10.171.174.1
         81.166.112.0/29-10.171.174.1
         81.166.113.0/24-10.171.174.1
         84.234.204.0/23-10.171.174.1
         84.234.250.128/25-10.171.174.1
         109.247.114.207/32-10.171.174.1
         109.247.114.209/32-10.171.174.1
         109.247.114.217/32-10.171.174.1
         109.247.116.128/27-10.171.174.1
         109.247.117.0/25-10.171.174.1
         109.247.118.0/24-10.171.174.1
         172.16.4.0/22-10.171.174.1
         172.21.0.0/16-10.171.174.1
         213.167.98.0/26-10.171.174.1
Dersom man har mulighet til det, så kan det jo være lurt å automatisere oppdatering av ruting via VLAN 101 basert på DHCP. Da slipper du brekkasje neste gang noe endres hos Altibox.
Sitat av bmork Vis innlegg

Dersom man har mulighet til det, så kan det jo være lurt å automatisere oppdatering av ruting via VLAN 101 basert på DHCP. Da slipper du brekkasje neste gang noe endres hos Altibox.
Vis hele sitatet...
Hvordan gjør man det?
Sitat av KydeX Vis innlegg
Hvordan gjør man det?
Vis hele sitatet...
fremgansmåte står her:

https://github.com/trrunde/routercon...rb4011-altibox
Ok, nå har jeg noen spørsmål her igjen Nettverkegenskapene er jo ikke så alt for høye, og lenge siden jeg satt med det her sist etter å ha fulgt en grei guide her inne. Nå har jeg kommet dit at TV ikke fungerte lenger, noe som er helt greit da den nesten ikke ble brukt like vel. Så vi kvitter oss med den og går samtidig litt ned på hastigheten da vi virkelig ikke har behov for 500/500. Men nok om det. Det jeg egentlig lurte på er om det trengs å ha 102 på eth5 som vist på bildet?



Av nysgjerrighet; er det noen som har undersøkt hvordan Altibox løser nettverksbiten mtp. IPTV på "ny" TV-løsning når Altibox-ruteren er satt i bromodus, og man kobler STB-ene direkte mot Altibox-ruteren? (LAN1+2 på FMG til TV, LAN3 til egen ruter).

Har de fikset det slik at STB-ene ikke lenger trenger internett-tilgang? De måtte jo ha det i starten (var kun 172.21.0.0/16 som måtte gå via VLAN101, mens resten gikk via internett), og vil jo tro at de fortsatt trenger det pga. Netflix-tilgang og annet? Alternativt så må de ha åpnet opp for at man kan ha to public-IP-er? (én til LAN3 + én til Altibox-ruter, som deretter STB-ene NAT-es bak). Eller har de implementert noe CGNAT-greier, slik at RFC1918-adressene som STB-ene mottar på VLAN101 faktisk har begrenset tilgang til internett?

Helt i starten når ny TV-løsning ble lansert, så hadde de jo ikke støtte for bromodus, nettopp fordi STB-ene krevde internett-tilgang.
▼ ... over en uke senere ... ▼
Eg har prøvd ei god stund å lese denne tråden, men eg kan umulig lese heile greia. Eg prøver kanskje å gjere noko ganske rart, I at eg har tilgang til alle tre nyeste altiboxruterene, men dei kommer fra El-avfall, og eg veit ikkje om dei fungerer. Eg har tatt med ein vmg, som sannsynlegvis ikkje fungerer, eg såg ein fmg, men tok den ikkje med heim av ein eller anna grunn, skjølv om eg tok med heim ein p2812ac som sannsynlegvis fungerer, men gir meg ikkje Internett gjennom kabel. Målet mitt er å bruke ein av dei som ein ruter for å erstatte den eg har allerede. Problemet mitt er at inntaket mitt går allerede gjennom ein hjemmesentral, så eg må kunne installere eit nytt firmware på den uten tilgang til altibox min side som gjer at eg kan bruke den som ein vanleg ruter. Om nokon kan bekrefte om dette er mulig eller ikkje hadde det vært veldig kjekt, men om det tar ein dags arbeid for å laste opp nytt firmware eller eit spesielt nettverkskort eller noko kjem eg sikkert berre til å kjøpe ein wifi-6 ruter, ettersom eg er litt lei av rutere med irritasjonsmoment. Eg har to rt-ac66u som kobler fra Wan minst ein gang til dagen, og er litt lei. Eine låner eg av far min, andre fant eg I el-avfallet den og. Sistnevnte funka fint ein dag, men etter kvart blei den værre enn den førstnevnte.
Hei,
Long time lurker her!
Jeg kjører pfsense på en enkel ESXi host som har single nic.
ESXi hosten er koblet til en 3560CX som har fiber mot Altibox.
Internett - Vlan102 fungerte mer eller mindre rett utav boksen.
IPTV - Vlan101 derimot sliter jeg med å få til.

Jeg har laget WANIPTV interface med DHCP, "dhcp-class-identifier "VMG8825-B50B"" og "subnet-mask, routers, broadcast-address, classless-routes".
Dette ser ut til å fungere iogmed at jeg får IP og jeg ser routes annonsert via DHCP.

Kode

[2.4.5-RELEASE][admin@pfSense.localdomain]/root: netstat -nr | grep 10.194
10.133.0.0/16      10.194.4.1         UGS    vmx0.101
10.194.4.0/23      link#8             U      vmx0.101
10.194.4.126       link#8             UHS         lo0
81.166.112.0/29    10.194.4.1         UGS    vmx0.101
81.166.113.0/24    10.194.4.1         UGS    vmx0.101
84.234.204.0/23    10.194.4.1         UGS    vmx0.101
84.234.250.128/25  10.194.4.1         UGS    vmx0.101
109.247.114.207/32 10.194.4.1         UGS    vmx0.101
109.247.114.209/32 10.194.4.1         UGS    vmx0.101
109.247.114.217/32 10.194.4.1         UGS    vmx0.101
109.247.116.128/27 10.194.4.1         UGS    vmx0.101
109.247.117.0/25   10.194.4.1         UGS    vmx0.101
109.247.118.0/24   10.194.4.1         UGS    vmx0.101
172.16.4.0/22      10.194.4.1         UGS    vmx0.101
172.21.0.0/16      10.194.4.1         UGS    vmx0.101
213.167.98.0/26    10.194.4.1         UGS    vmx0.101
Videre har jeg enablet IGMP proxy og satt WANIPTV interface som upstream interface med 10.133.0.0/16 og 172.21.0.0/16 som upstream adresser.
Jeg har satt IPTV_INSIDE interface som downstream interface uten å spesifisere noen routes.

FW regler er satt opp rimelig enkelt for å få IPTV opp å kjøre.
På WANIPTV og IPTV_INSIDE har jeg satt allow any any ipv4 og krysset av for "Allow packets with IP options to pass. Otherwise they are blocked by default. This is usually only seen with multicast traffic."

3560CX får Altibox inn på gi0/15(vlan101 og vlan102)
gi0/1 er trunk til esxi hvor jeg tillater alle vlan(4095 på esxi)
gi0/5 er accessport i vlan90(INSIDE_IPTV)

Jeg får ikke IPTV omså livet står på spill(noe det snart gjør om ikke fruen får tv i orden).
Hva er det jeg misser?
Sist endret av jimpix; 4 uker siden kl. 16:19.
Har et relativt likt opplegg med fiberen til en 3560cx med ett bein til ruter. Bare med en annen ruter. Oppsettet ditt burde bare virke.

Sjekke at stb får adresse fra pfsense og at du NATer den videre ut på vlan 101? Sjekke at 3560 ser igmp på de forventede portene og vlan? sh ip igmp snoop groups er ofte opplysende
Jeg har nattet 192.168.90.0/24 til WANIPTV gw.

Se bildet, https://imgur.com/a/mRfS3K9
Er det noen som har fått IPTV til å fungere (Q22 dekoder på ny Lyse Altibox platform) ved bruk av VLAN og Unifi switcher?

Jeg har eg relativt enkelt oppsett:
- Altibox FMG i bridge mode
- Ubiquiti Edgerouger 6P Router (koblet til FMG port 3)
- Unifi 8P POE switch (koblet til Edgerouter for internett tilgang og FMG port 1 for IPTV over VLAN101)

Tanken er å bruke Edgerouter som router og samtidig ha mulighet for å trunke Internett og IPTV på samme kabel rundt i huset.

Jeg har aktivert IGMP snooping på VLAN101 i Unifi controller. Henter ut VLAN101 untagged på de portene som går direkte til Q22 dekoder.

Q22 får IP i 192.168.0.x range og starter opp som normalt. Etter noen sekunder begynner bildet å hakke før det blir helt svart. Dersom jeg trykker pause og deretter play (tidsforskjøvet visning) fungerer det fint. Dette er jo litt irriterende og det hadde vært fint å bli kvitt problemet. Forstår det kan skyldes at streamen endres fra unicast til multicast etter ca 15-20sek. Dersom jeg plugger Q22 direkte i port 1 på FMG fungerer alt fint.

Har også forsøkt å deaktivere «IGMP host header validation» via console/telnet på Unifi switchene uten at det gjorde noen forskjell.

Ønsker å unngå å kjøre både WAN og IPTV gjennom EdgeRouter (oppsett med IGMP proxy etc da dette har vist seg utfordrende å vedlikeholde når Altibox foretar endringer).

Er det Unifi switchene som er problemet eller er det noe jeg har misset?

Takk for tips
Dersom q22 blir satt i vlan 101 så skal den få 10.x ipadresse. Siden den får 192.168.0.x så vil jeg tippe du har satt den på ditt eget lan.
Takk for tips - men Q22 får IP i 192.168.0.x også når den plugges direkte i port 1 på FMG. Mulig man får i 10.x når FMG ikke står i bridge mode? Er kanskje også mulig at dette løses forskjellig av de forskjellige Altibox leverandørene.

Lokalt LAN er i 192.168.3.x så det er ihvertfall ikke lokal DHCP som gir ut IP til Q22.
Sist endret av cregeland; 4 uker siden kl. 12:34.
ahh stemmer ja, har blitt endringer så fmg kjører igmp proxy uansett om du kjører bridge mode eller routed modus.

har du sett i forumet til ubiquiti?
https://community.ui.com/questions/M...e-a62a217bdcc5
Om noen erfarer samme problem som meg der IPTV config tilsynelatende ser korrekt ut, så dobbelsjekk routing på DNS.
Jeg hadde satt DNS under System -> General 92.220.228.70 og 109.247.114.4 men ikke spesifisert GW.
Jeg router 109.247.114.4 ut på IPTV interface men denne blir overstyrt når man ikke spesifiserer GW i GUI.
Alt fungerer nå etter jeg slettet DNS under System -> General og opprettet statisk route mot 109.247.114.4 IPTV GW.

Men, er det noen som kan svare på hvordan de router Altibox DNS?
Nå må jeg route 92.220.228.70 via vlan102 og 109.247.114.4 via vlan101. Det vil si at 109.247.114.4 ikke er reachable fra "internett" for min del.
Sist endret av jimpix; 4 uker siden kl. 10:42.
begge dns adressene er tilgjengelig både på vlan 101 og 102. Gir ikke mening at det skal ha begynt å virke når du routed dns trafikken din via vlan 101. Du treffer de samme anycast serverne uansett og de serverer deg samme svaret på forespørslene uansett om du kommer fra en offentlig ip eller en 10.x ip.
Sitat av Trrunde Vis innlegg
har du sett i forumet til ubiquiti?
https://community.ui.com/questions/M...e-a62a217bdcc5
Vis hele sitatet...
Takk for link - har kikket litt på forumet der og det ser ut som fellesnevneren som regel er igmp proxy eller manglende igmp snooping. Det blir vel ikke helt relevant i mitt tilfelle hvor IPTV går helt utenom routeren?

Jeg bypasser routeren og fordeler bare VLAN101 til dekoderne ved hjelp av managed switch. Dekoderne vil dermed ikke se eller ha tilgang til lokal router - kun VLAN101 som kommer direkte fra FMG?
igmp snooping vil være en fordel da du slipper å sende ut multicast på alle portene på switchen din.

Lag en tegning med hvordan du har koblet sammen utstyret ditt og legg på en beskrivelse som sier noe om hvilke port er satt i hvilke modus (access / trunk) og hvilke vlan de forskjellige portene har satt opp med.
Oh store orakler! Her har jeg lest alle sidene opp og ned i mente, og fikk dette fint opp å gå for en stund siden. Takk for det!

Jeg har nå fått meg en cisco 3650 switch, og den er bare "litt" mer kronglete enn den gamle switchen...

Jeg skulle teste i går(bytte til ny switch), og da fikk jeg kun NRK til å fungere, men så at det har kommet en ny static route, så fikk lagt inn den, og da fikk jeg resten av kanalene opp å gå, dog kun med unicast...

koblet opp edgerouter til gammel switch, og dekoder på denne, med cisco "bypasset" da funket det fint.

Kan legge ved hele oppsettet hvis det er ønskelig, men det funker med en "simpel" managed switch, og ikke trollet av en cisco.

Så da er spørsmålet, hvordan får jeg 3650 en til å være med å leke med multicast?

Har satt den i PIm sparse mode, og enablet igmp snooping.

legger ved noe av multicast oppsettet jeg har prøvd meg på:

Kode

Cisco#show ip igmp interface
Loopback0 is up, line protocol is up
  Internet protocol processing disabled
Vlan1 is up, line protocol is up
  Internet address is 192.168.1.20/24

Kode

Cisco#show ip pim autorp
AutoRP Information:
  AutoRP is enabled.
  RP Discovery packet MTU is 0.
  224.0.1.40 is joined on Vlan1.
  AutoRP groups over sparse mode interface is enabled

PIM AutoRP Statistics: Sent/Received
  RP Announce: 0/0, RP Discovery: 0/0

  IGMP is enabled on interface
  Current IGMP host version is 2
  Current IGMP router version is 2
  IGMP query interval is 60 seconds
  IGMP configured query interval is 60 seconds
  IGMP querier timeout is 120 seconds
  IGMP configured querier timeout is 120 seconds
  IGMP max query response time is 10 seconds
  Last member query count is 2
  Last member query response interval is 1000 ms
  Inbound IGMP access group is not set
  IGMP activity: 1 joins, 0 leaves
  Multicast routing is enabled on interface
  Multicast TTL threshold is 0
  Multicast designated router (DR) is 192.168.1.20 (this system)
  IGMP querying router is 192.168.1.1
  IGMP unidirectional link multicast routing enabled
  Multicast groups joined by this system (number of users):
      224.0.1.40(1)

Kode

Cisco#show ip multicast interface
Loopback0 is up, line protocol is up
  Internet protocol processing: disabled
Vlan1 is up, line protocol is up
  Internet address is 192.168.1.20/24
  Multicast routing: enabled
  Multicast switching: process
  Multicast packets in/out: 0/0
  Multicast TTL threshold: 0
  Multicast Tagswitching: disabled
Håper dere skjønner hva jeg mener, og kanskje ser hvor jeg har gått feil
Sitat av Trrunde Vis innlegg
Lag en tegning med hvordan du har koblet sammen utstyret ditt og legg på en beskrivelse som sier noe om hvilke port er satt i hvilke modus (access / trunk) og hvilke vlan de forskjellige portene har satt opp med.
Vis hele sitatet...
Her er en enkel skisse. IGMP snooping er enabled for VLAN101. har prøvd uten IGMP snooping også (begrenset skade i og med at det kun gjelder VLAN101) men det gjorde ingen forskjell.

Port 3-5 på switch #1 og port 3-8 på switch #2 har VLAN1 untagged

Tusen takk for hjelp

Sist endret av cregeland; 4 uker siden kl. 23:54.
Sitat av cregeland Vis innlegg
Her er en enkel skisse. IGMP snooping er enabled for VLAN101. har prøvd uten IGMP snooping også (begrenset skade i og med at det kun gjelder VLAN101) men det gjorde ingen forskjell.

Port 3-5 på switch #1 og port 3-8 på switch #2 har VLAN1 untagged

Tusen takk for hjelp

Vis hele sitatet...


Mener det oppsettet burde virke. Oppfører Q22 som er koblet på switch01 likt som den som er koblet på switch02 ?
Har samme switchene som deg, men jeg har en mikrotik koblet på foran og har Q22 direkte på denne, så har aldri testet multicast trafikk på de switchene.
Sitat av Trrunde Vis innlegg
Mener det oppsettet burde virke. Oppfører Q22 som er koblet på switch01 likt som den som er koblet på switch02 ?
Vis hele sitatet...
Q22 på switch #1 har samme oppførsel som switch #2. Jeg har også ett oppsett på en annen lokasjon hvor jeg bruker UDM-PRO med samme prinsipp - men uten Unifi 8P-POE 60w switcher. På den lokasjonen er det bare 1x Q22 som da står direkte i UDM-PRO. Dette fungerer utmerket. Routeren får da VLAN101 og VLAN102 fra FMG på samme måte som Unifi switchen gjør i scenarioet vi diskuterer her.

Det som er underlig er at dette har fungert helt fint i en lang periode. Jeg oppgraderte i et svakt øyeblikk til siste Unifi firmware på switchene (4.21) og dette kan se ut til å ha ført til problemene vi nå diskuterer. Har ikke klart å fastsette 100% at problemene startet på nøyaktig samme tidspunkt som firmware upgrade. Har likevel downgradet til forrige version (4.20) som fungerte fint tidligere - men problemet har blitt værende.

Kan det hende at det mangler en IGMP querier - eller er det noe med Multicast på Unifi switchene? Jeg har forstått at det må være en IGMP querier som «organiserer» IGMP snoopingen, men er usikker på om en slik service kjører på switchene - eller om det i det hele er nødvendig i dette scenarioet.

Når jeg telnet´er inn på switchen ser jeg at multicast packet counter øker (sakte - gjerne 10 packets pr min) selv mens IPTV streamen hakker.
Sist endret av cregeland; 4 uker siden kl. 23:32.
Altibox sin ZyXEL P-2812 tok kveld og eg koblet den vekk. Bruker nå en Asus RT-AC87U etter HET-3012 fra altibox. Eg får internett på Vlan 102, men 101 (tv) gir dekoderen (q22) feilmelding Unknown error #102000. Har nye altibox løsningen om det er beytydning. Har lagt inn ZyXEL P-2812 sin MAC som klone.

Fra asus LAN-IPTV:
Bruke DHCP-rutere Microsoft
Multikastrutelegging (IGMP Proxy) Aktiver
Eeffektiv multikastingvideresending (IGMP-snooping) Deaktiver
UDP Proxy(Udpxy) 0
Sitat av salomonsen Vis innlegg
Altibox sin ZyXEL P-2812 tok kveld og eg koblet den vekk. Bruker nå en Asus RT-AC87U etter HET-3012 fra altibox. Eg får internett på Vlan 102, men 101 (tv) gir dekoderen (q22) feilmelding Unknown error #102000. Har nye altibox løsningen om det er beytydning. Har lagt inn ZyXEL P-2812 sin MAC som klone.

Fra asus LAN-IPTV:
Bruke DHCP-rutere Microsoft
Multikastrutelegging (IGMP Proxy) Aktiver
Eeffektiv multikastingvideresending (IGMP-snooping) Deaktiver
UDP Proxy(Udpxy) 0
Vis hele sitatet...
Jeg tror ikke du får det der til med den routeren. Det holder ikke å bare route Vlan 101 til dekoderen, den må ha internett også på visse ip-ranger via statisk rute. Jeg prøvde med en lik router som din, men ga opp og kjøpte en Microtik i stedet.
Så ut til at jeg fikk løst det på cisco switchen

Måtte enable RGMP på vlan 1.

Det jeg ikke helt forstår er hvorfor skal man måtte kjøre pim, for å enable IGMP, da slik jeg forstår det at PIM er en routing protokoll som man ikke får med vanlig lanbase lisens...

Uansett, det kan jo være kjekt for noen andre der ute å vite hvis de kommer over samme

Kode

Cisco#show ip igmp groups
IGMP Connected Group Membership
Group Address    Interface                Uptime    Expires   Last Reporter   Group Accounted
233.89.188.1     Vlan1                    00:05:04  00:02:57  192.168.1.120
239.255.255.251  Vlan1                    00:05:03  00:02:57  192.168.1.145
239.255.255.250  Vlan1                    00:05:04  00:02:56  192.168.1.164
239.255.3.22     Vlan1                    00:05:03  00:02:02  192.168.1.39
239.202.2.80     Vlan1                    00:05:04  00:02:57  192.168.1.139
239.254.127.63   Vlan1                    00:05:03  00:02:55  192.168.1.140
Smørbrød liste blir da som følger:
Dit interface må ha en IP adresse for at dette skal funke
Enable
configure terminal
ip multicast-routing
ip pim sparse-mode
interface *ditt interface*
IP pim passive
IP RGMP
exit
IP igmp snooping *ditt interface*
end
write memory eller copy running config startup config

Tror jeg
Sist endret av Vdomagix; 3 uker siden kl. 12:29. Grunn: La til mer info
Sitat av KydeX Vis innlegg
Jeg tror ikke du får det der til med den routeren. Det holder ikke å bare route Vlan 101 til dekoderen, den må ha internett også på visse ip-ranger via statisk rute. Jeg prøvde med en lik router som din, men ga opp og kjøpte en Microtik i stedet.
Vis hele sitatet...
Takk for tilbakemelding.
Fikk ny hjemmesentral av type VMG nå, regner med den oppfører seg bedre enn P2812.
▼ ... over en uke senere ... ▼
Hei

I morgen, mandag får jeg installert Altibox. Regnet med at vi skulle få VMG sentralen. Men ser nå at vi får FMG.
Regnet jo med at vi ville få den nyeste sentralen... Er det store forskjeller på disse to sentralene?

Jeg skriver vi pga at vi er et borettslag :-)
Hei

Har i dag nye hjemmesentral fra altibox og q22 dekodere

Med en edgerouter x, vil det være mulig å kjøre rj45 fra media converter rett inn i denne. Og så kunne bruke de «ledige» portene på edgerouter på samme måte som altibox sentralen?

Der kan jeg trekke en kabel fra hvilken som helst Lan port ned til stuen. Deretter inn i en switch. Ut fra switch til tv og ps4. Får tv og nett via samme kabel fra hjemmesentral.

Ønsker å fjerne hjemmesentral siden den hele tiden må startes på nytt.

Sitat av Ott Vis innlegg
Hei

I morgen, mandag får jeg installert Altibox. Regnet med at vi skulle få VMG sentralen. Men ser nå at vi får FMG.
Regnet jo med at vi ville få den nyeste sentralen... Er det store forskjeller på disse to sentralene?

Jeg skriver vi pga at vi er et borettslag :-)
Vis hele sitatet...

Jeg byttet nettopp fra fmg til vgm. Var ikke noen forskjell på dem. Grunnen til at jeg bytta var at cpu hadde hengt seg så sentral jobbet på 100% konstant
Sist endret av Olstig; 2 uker siden kl. 20:16. Grunn: Automatisk sammenslåing med etterfølgende innlegg.
Hei



Har kabel fra mediakonverter til min Edgerouter-X på port eth0.
Ønsker internett og iptv ut på eth1



Oppsettet mitt er i dag:
Hjemmesentral VGM -> TP-Link Switch -> 1stk kabel til tv dekoder Q22. - , og 1 kabel til playstation (internett)

Med dette oppsettet kjøres altså nett og iptv i samme kabel fra hjemmesentral til switch, hvor jeg kan hente ut det jeg måtte ønske fra switch.

Har prøvd meg frem og fått mye god hjelp, men nå står jeg litt fast. Internett fungerer, men tv hakker. Står også at tv er utilgjengelig, men nrk kanalene fungerer.

Dette er min config.. (Har fjernet MAC-adressen)

firewall {
all-ping enable
broadcast-ping disable
ipv6-name WANv6_IN {
default-action drop
description "WAN inbound traffic forwarded to LAN"
enable-default-log
rule 10 {
action accept
description "Allow established/related sessions"
state {
established enable
related enable
}
}
rule 20 {
action drop
description "Drop invalid state"
state {
invalid enable
}
}
}
ipv6-name WANv6_LOCAL {
default-action drop
description "WAN inbound traffic to the router"
enable-default-log
rule 10 {
action accept
description "Allow established/related sessions"
state {
established enable
related enable
}
}
rule 20 {
action drop
description "Drop invalid state"
state {
invalid enable
}
}
rule 30 {
action accept
description "Allow IPv6 icmp"
protocol ipv6-icmp
}
rule 40 {
action accept
description "allow dhcpv6"
destination {
port 546
}
protocol udp
source {
port 547
}
}
}
ipv6-receive-redirects disable
ipv6-src-route disable
ip-src-route disable
log-martians enable
name WAN_IN {
default-action drop
description "WAN to internal"
rule 10 {
action accept
description "Allow established/related"
state {
established enable
related enable
}
}
rule 20 {
action drop
description "Drop invalid state"
state {
invalid enable
}
}
}
name WAN_LOCAL {
default-action drop
description "WAN to router"
rule 10 {
action accept
description "Allow established/related"
state {
established enable
related enable
}
}
rule 20 {
action drop
description "Drop invalid state"
state {
invalid enable
}
}
}
receive-redirects disable
send-redirects enable
source-validation disable
syn-cookies enable
}
interfaces {
ethernet eth0 {
address dhcp
description Internet
duplex auto
firewall {
in {
ipv6-name WANv6_IN
name WAN_IN
}
local {
ipv6-name WANv6_LOCAL
name WAN_LOCAL
}
}
speed auto
vif 101 {
address dhcp
description IPTV
dhcp-options {
default-route no-update
default-route-distance 210
name-server update
}
mac XX:XX:XX:XX:XX
}
vif 102 {
address dhcp
description Internet
firewall {
in {
name WAN_IN
}
local {
name WAN_LOCAL
}
}
}
}
ethernet eth1 {
description Local
duplex auto
speed auto
}
ethernet eth2 {
description Local
duplex auto
speed auto
}
ethernet eth3 {
description Local
duplex auto
speed auto
}
ethernet eth4 {
description Local
duplex auto
speed auto
}
loopback lo {
}
switch switch0 {
address 192.168.1.1/24
description Local
mtu 1500
switch-port {
interface eth1 {
}
interface eth2 {
}
interface eth3 {
}
interface eth4 {
}
vlan-aware disable
}
}
}
protocols {
igmp-proxy {
interface eth0.101 {
alt-subnet 172.21.0.0/16
role upstream
threshold 1
}
interface eth1 {
alt-subnet 0.0.0.0/0
role downstream
threshold 1
}
}
}
service {
dhcp-server {
disabled false
hostfile-update disable
shared-network-name LAN {
authoritative enable
subnet 192.168.1.0/24 {
default-router 192.168.1.1
dns-server 192.168.1.1
lease 86400
start 192.168.1.38 {
stop 192.168.1.243
}
}
}
static-arp disable
use-dnsmasq disable
}
dns {
forwarding {
cache-size 150
listen-on switch0
}
}
gui {
http-port 80
https-port 443
older-ciphers enable
}
nat {
rule 5000 {
description "Masquerade LAN to WAN"
log disable
outbound-interface eth0.102
protocol all
source {
address 192.168.1.0/24
}
type masquerade
}
rule 5010 {
description "masquerade for WAN"
outbound-interface eth0
type masquerade
}
}
ssh {
port 22
protocol-version v2
}
}
system {
host-name ubnt
login {
user XXX {
authentication {
encrypted-password XXXX/
}
level admin
}
}
ntp {
server 0.ubnt.pool.ntp.org {
}
server 1.ubnt.pool.ntp.org {
}
server 2.ubnt.pool.ntp.org {
}
server 3.ubnt.pool.ntp.org {
}
}
syslog {
global {
facility all {
level notice
}
facility protocols {
level debug
}
}
}
time-zone UTC
}
Sist endret av Olstig; 2 uker siden kl. 08:37. Grunn: hele config vises ikke
Mulig dette er et duste spm, men har skummet igjennom gamle tråden og denne, samt forsøkt å søke litt i forumet, men ikke fått helt klart svar. Er det mulig å hente ut IPTV fra altibox (har Q22 dekoder) inkludert krypterte kanaler, og faktisk se dem i tvheadend (eller annen software)?
Sitat av Olstig Vis innlegg
Hei



Har kabel fra mediakonverter til min Edgerouter-X på port eth0.
Ønsker internett og iptv ut på eth1



Oppsettet mitt er i dag:
Hjemmesentral VGM -> TP-Link Switch -> 1stk kabel til tv dekoder Q22. - , og 1 kabel til playstation (internett)

Med dette oppsettet kjøres altså nett og iptv i samme kabel fra hjemmesentral til switch, hvor jeg kan hente ut det jeg måtte ønske fra switch.

Har prøvd meg frem og fått mye god hjelp, men nå står jeg litt fast. Internett fungerer, men tv hakker. Står også at tv er utilgjengelig, men nrk kanalene fungerer.

Dette er min config.. (Har fjernet MAC-adressen)

firewall {
all-ping enable
broadcast-ping disable
ipv6-name WANv6_IN {
default-action drop
description "WAN inbound traffic forwarded to LAN"
enable-default-log
rule 10 {
action accept
description "Allow established/related sessions"
state {
established enable
related enable
}
}
rule 20 {
action drop
description "Drop invalid state"
state {
invalid enable
}
}
}
ipv6-name WANv6_LOCAL {
default-action drop
description "WAN inbound traffic to the router"
enable-default-log
rule 10 {
action accept
description "Allow established/related sessions"
state {
established enable
related enable
}
}
rule 20 {
action drop
description "Drop invalid state"
state {
invalid enable
}
}
rule 30 {
action accept
description "Allow IPv6 icmp"
protocol ipv6-icmp
}
rule 40 {
action accept
description "allow dhcpv6"
destination {
port 546
}
protocol udp
source {
port 547
}
}
}
ipv6-receive-redirects disable
ipv6-src-route disable
ip-src-route disable
log-martians enable
name WAN_IN {
default-action drop
description "WAN to internal"
rule 10 {
action accept
description "Allow established/related"
state {
established enable
related enable
}
}
rule 20 {
action drop
description "Drop invalid state"
state {
invalid enable
}
}
}
name WAN_LOCAL {
default-action drop
description "WAN to router"
rule 10 {
action accept
description "Allow established/related"
state {
established enable
related enable
}
}
rule 20 {
action drop
description "Drop invalid state"
state {
invalid enable
}
}
}
receive-redirects disable
send-redirects enable
source-validation disable
syn-cookies enable
}
interfaces {
ethernet eth0 {
address dhcp
description Internet
duplex auto
firewall {
in {
ipv6-name WANv6_IN
name WAN_IN
}
local {
ipv6-name WANv6_LOCAL
name WAN_LOCAL
}
}
speed auto
vif 101 {
address dhcp
description IPTV
dhcp-options {
default-route no-update
default-route-distance 210
name-server update
}
mac XX:XX:XX:XX:XX
}
vif 102 {
address dhcp
description Internet
firewall {
in {
name WAN_IN
}
local {
name WAN_LOCAL
}
}
}
}
ethernet eth1 {
description Local
duplex auto
speed auto
}
ethernet eth2 {
description Local
duplex auto
speed auto
}
ethernet eth3 {
description Local
duplex auto
speed auto
}
ethernet eth4 {
description Local
duplex auto
speed auto
}
loopback lo {
}
switch switch0 {
address 192.168.1.1/24
description Local
mtu 1500
switch-port {
interface eth1 {
}
interface eth2 {
}
interface eth3 {
}
interface eth4 {
}
vlan-aware disable
}
}
}
protocols {
igmp-proxy {
interface eth0.101 {
alt-subnet 172.21.0.0/16
role upstream
threshold 1
}
interface eth1 {
alt-subnet 0.0.0.0/0
role downstream
threshold 1
}
}
}
service {
dhcp-server {
disabled false
hostfile-update disable
shared-network-name LAN {
authoritative enable
subnet 192.168.1.0/24 {
default-router 192.168.1.1
dns-server 192.168.1.1
lease 86400
start 192.168.1.38 {
stop 192.168.1.243
}
}
}
static-arp disable
use-dnsmasq disable
}
dns {
forwarding {
cache-size 150
listen-on switch0
}
}
gui {
http-port 80
https-port 443
older-ciphers enable
}
nat {
rule 5000 {
description "Masquerade LAN to WAN"
log disable
outbound-interface eth0.102
protocol all
source {
address 192.168.1.0/24
}
type masquerade
}
rule 5010 {
description "masquerade for WAN"
outbound-interface eth0
type masquerade
}
}
ssh {
port 22
protocol-version v2
}
}
system {
host-name ubnt
login {
user XXX {
authentication {
encrypted-password XXXX/
}
level admin
}
}
ntp {
server 0.ubnt.pool.ntp.org {
}
server 1.ubnt.pool.ntp.org {
}
server 2.ubnt.pool.ntp.org {
}
server 3.ubnt.pool.ntp.org {
}
}
syslog {
global {
facility all {
level notice
}
facility protocols {
level debug
}
}
}
time-zone UTC
}
Vis hele sitatet...
skumleste bare config, fant hvertfall to ting som var feil.
Du mangler statiske router for tv-prefix, du mangler også nat på vlan 101

så kan du ta bort nat på eth0
Hei. Takk for svar.
Leser lengre opp i posten her at ip-adresse er endret til 10.133.0.0/16 ifra 172.x.x.x/16.

Kunne du hjulpet meg med å korrigere statiske router for tv-prefix, og det med nat på vlan 101?

Nå er config slik:

Da kommer hvertfall tv portalen opp. men tv2 osv er sorte. nrk fungerer.

firewall {
all-ping enable
broadcast-ping disable
ipv6-name WANv6_IN {
default-action drop
description "WAN inbound traffic forwarded to LAN"
enable-default-log
rule 10 {
action accept
description "Allow established/related sessions"
state {
established enable
related enable
}
}
rule 20 {
action drop
description "Drop invalid state"
state {
invalid enable
}
}
}
ipv6-name WANv6_LOCAL {
default-action drop
description "WAN inbound traffic to the router"
enable-default-log
rule 10 {
action accept
description "Allow established/related sessions"
state {
established enable
related enable
}
}
rule 20 {
action drop
description "Drop invalid state"
state {
invalid enable
}
}
rule 30 {
action accept
description "Allow IPv6 icmp"
protocol ipv6-icmp
}
rule 40 {
action accept
description "allow dhcpv6"
destination {
port 546
}
protocol udp
source {
port 547
}
}
}
ipv6-receive-redirects disable
ipv6-src-route disable
ip-src-route disable
log-martians enable
name WAN_IN {
default-action drop
description "WAN to internal"
rule 10 {
action accept
description "Allow established/related"
state {
established enable
related enable
}
}
rule 20 {
action drop
description "Drop invalid state"
state {
invalid enable
}
}
}
name WAN_LOCAL {
default-action drop
description "WAN to router"
rule 10 {
action accept
description "Allow established/related"
state {
established enable
related enable
}
}
rule 20 {
action drop
description "Drop invalid state"
state {
invalid enable
}
}
}
receive-redirects disable
send-redirects enable
source-validation loose
syn-cookies enable
}
interfaces {
ethernet eth0 {
address dhcp
description Internet
duplex auto
firewall {
in {
ipv6-name WANv6_IN
name WAN_IN
}
local {
ipv6-name WANv6_LOCAL
name WAN_LOCAL
}
}
speed auto
vif 101 {
address dhcp
description IPTV
dhcp-options {
default-route no-update
default-route-distance 210
name-server update
}
mac XX:XX:XX:XX:XX
}
vif 102 {
address dhcp
description Internet
firewall {
in {
name WAN_IN
}
local {
name WAN_LOCAL
}
}
}
}
ethernet eth1 {
description Local
duplex auto
speed auto
}
ethernet eth2 {
description Local
duplex auto
speed auto
}
ethernet eth3 {
description Local
duplex auto
speed auto
}
ethernet eth4 {
description Local
duplex auto
speed auto
}
loopback lo {
}
switch switch0 {
address 192.168.1.1/24
description Local
mtu 1500
switch-port {
interface eth1 {
}
interface eth2 {
}
interface eth3 {
}
interface eth4 {
}
vlan-aware disable
}
}
}
protocols {
igmp-proxy {
interface eth0.101 {
alt-subnet 172.21.0.0/16
role upstream
threshold 1
}
interface eth1 {
alt-subnet 0.0.0.0/0
alt-subnet 10.0.0.1/8
role downstream
threshold 1
}
}
static {
route 10.133.0.0/16 {
next-hop 10.202.112.1 {
description IPTV_2
distance 1
}
}
route 172.21.0.0/16 {
next-hop 10.174.210.1 {
distance 1
}
}
}
}
service {
dhcp-server {
disabled false
hostfile-update disable
shared-network-name LAN {
authoritative enable
subnet 192.168.1.0/24 {
default-router 192.168.1.1
dns-server 192.168.1.1
lease 86400
start 192.168.1.38 {
stop 192.168.1.243
}
}
}
static-arp disable
use-dnsmasq disable
}
dns {
forwarding {
cache-size 150
listen-on switch0
}
}
gui {
http-port 80
https-port 443
older-ciphers enable
}
nat {
rule 5000 {
description "Masquerade LAN to WAN"
log disable
outbound-interface eth0.102
protocol all
source {
address 192.168.1.0/24
}
type masquerade
}
rule 5001 {
description "Masquerade LAN to WAN"
log disable
outbound-interface eth0.101
protocol all
source {
address 192.168.1.0/24
}
type masquerade
}
}
ssh {
port 22
protocol-version v2
}
unms {
disable
}
}
system {
host-name ubnt
login {
user Stig {
authentication {
encrypted-password $6$vMvYS4I1mDO$UIGCRPXRvGz/BTkEpqapgMQCnEBeP2ZAFxkCzThPWHVKNDSi7D6jEQcHj.2sghNYzqZyZiCj 319PILbWv2Aqd/
}
level admin
}
}
ntp {
server 0.ubnt.pool.ntp.org {
}
server 1.ubnt.pool.ntp.org {
}
server 2.ubnt.pool.ntp.org {
}
server 3.ubnt.pool.ntp.org {
}
}
offload {
hwnat enable
ipsec enable
}
syslog {
global {
facility all {
level notice
}
facility protocols {
level debug
}
}
}
time-zone Europe/Oslo
}

ser noen noen umiddelbare feil?
Sist endret av Olstig; 2 uker siden kl. 12:27. Grunn: Automatisk sammenslåing med etterfølgende innlegg.
Sitat av Olstig Vis innlegg
ser noen noen umiddelbare feil?
Vis hele sitatet...
De statiske rutene dine ser merkelige ut. Jeg vil anbefale å bare bruke Trrunde's DHCP-løsning. Mye enklere og robust i forhold til fremtidige endringer i nettet.
han fikk løst det igår kveld. Ser ikke ut som ubiquiti installerer routene via dhcp opsjon i route tabellen, så de måtte legges inn statisk. Kan sikkert løses med et script på boksen som henter det fra dhcp og kjører inn statiske router automatisk.
Edgerouter henter ikke de statiske routene via dhcp option automatisk grunnet at den mangler følgende script-fil: "/etc/dhcp3/dhclient-exit-hooks.d/rfc3442-classless-routes". Grunnen til at den mangler er at ubiquiti ikke har implementert denne funksjonen offisielt enda. Men dette kan løses ved å manuelt opprette "rfc3442-classless-routes".

Kopier inn koden fra linken under og lagre filen som rfc3442-classless-routes i mappen /etc/dhcp3/dhclient-exit-hooks.d på edgerouter.
https://gist.github.com/kgersen/58c2...assless-routes

Deretter må den gjøres executable:
sudo chmod 755 /etc/dhcp3/dhclient-exit-hooks.d/rfc3442-classless-routes

Har gjort dette på en Edgerouter-X og det ser ut til å fungere perfekt.

Merk at ved firmware upgrade av edgerouter vil man måtte gjøre dette på nytt igjen. Så kan være lurt å lagre en kopi av "rfc3442-classless-routes" i mappen /config.
Sitat av fbt Vis innlegg
Edgerouter henter ikke de statiske routene via dhcp option automatisk grunnet at den mangler følgende script-fil: "/etc/dhcp3/dhclient-exit-hooks.d/rfc3442-classless-routes". Grunnen til at den mangler er at ubiquiti ikke har implementert denne funksjonen offisielt enda. Men dette kan løses ved å manuelt opprette "rfc3442-classless-routes".

Kopier inn koden fra linken under og lagre filen som rfc3442-classless-routes i mappen /etc/dhcp3/dhclient-exit-hooks.d på edgerouter.
https://gist.github.com/kgersen/58c2...assless-routes

Deretter må den gjøres executable:
sudo chmod 755 /etc/dhcp3/dhclient-exit-hooks.d/rfc3442-classless-routes

Har gjort dette på en Edgerouter-X og det ser ut til å fungere perfekt.

Merk at ved firmware upgrade av edgerouter vil man måtte gjøre dette på nytt igjen. Så kan være lurt å lagre en kopi av "rfc3442-classless-routes" i mappen /config.
Vis hele sitatet...

Det funka bra det ja.
Oppdaterte github siden med info om scriptet, pluss ipv6 på edgerouter

https://github.com/trrunde/routercon...uter-x-altibox