Dette nettstedet er avhengig av annonseinntekter for å holde driften og videre utvikling igang. Vi liker ikke reklame heller, men alternativene er ikke mange. Vært snill å vurder å slå på annonsevisning, eller å abonnere på en reklamefri utgave av nettstedet.
  3 977
Registrer deg for å skrive svar Trådrulett
Nawesome
Provo's Avatar
nFF Crew
okt. 2006
Jeg har en raspberry pi 2 med Raspbian Jessie. Til denne kjøpte jeg en TP-Link TL-WN725N, som ifølge Wikidevi har et RTL8188CUS chipset. Det er imidlertid fullt mulig at jeg har TL-WN725N v2, som ifølge samme side har et RTL8188EUS chipset.

Alt ser ut til å fungere, med unntak av at alle trådløse nett den finner oppgis å ha signalstyrke 0 (-1 i wicd), på tross av at den står svært nærme aksesspunktet. Om jeg forsøker å koble til, feiler den. Jeg er ikke kjempesterk på dette, og har ikke klart å fikse problemet. Her er ymse relevante outputs:

Kode

$ sudo lsusb
Bus 001 Device 006: ID 0bda:8179 Realtek Semiconductor Corp.

Kode

$ sudo lshw
…
        *-usb:3
             description: Wireless interface
             product: 802.11n NIC
             vendor: Realtek
             physical id: 5
             bus info: usb@1:1.5
             logical name: wlan0
             version: 0.00
             serial: 00E04C0001
             capabilities: usb-2.00 ethernet physical wireless
             configuration: broadcast=yes driver=r8188eu maxpower=500mA multicast=yes speed=480Mbit/s wireless=unassociated

Kode

$ ifconfig wlan0
wlan0     Link encap:Ethernet  HWaddr xx:xx:xx:xx:xx:xx  
          inet6 addr: fe80::xxxx:xxxx:xxxx:xxxx/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

Kode

$ iwlist wlan0 scanning        
wlan0     Scan completed :
          Cell 01 - Address: XX:XX:XX:XX:XX:XX
                    ESSID:"XXXXX"
                    Protocol:IEEE 802.11bgn
                    Mode:Master
                    Frequency:2.447 GHz (Channel 8)
                    Encryption key:on
                    Bit Rates:300 Mb/s
                    Extra:rsn_ie=30140100000fac040100000fac040100000fac020000
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
                    IE: Unknown: DD880050F204104A0001101044000102103B000103104700104A26823D553EAA3039CA48E363E4ADD11021000D4E4554474541522C20496E632E10230006455836313530102400064558363135301042000D343036323636373941303232421054000800060050F20400011011000645583631353010080002218C103C0001011049000600372A000120
                    Quality:0  Signal level:0  Noise level:0

Kode

$ iwconfig wlan0       
wlan0     unassociated  Nickname:"<WIFI@REALTEK>"
          Mode:Managed  Frequency=2.412 GHz  Access Point: Not-Associated   
          Sensitivity:0/0  
          Retry:off   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
For å rydde unna et par opplagte ting: Jeg har forsøkt å ta ned og opp interfacet med ifconfig down og up, jeg har forsøkt å reboote og firmware-realtek er installert.

Noen som har forslag og tips om hva som kan være problemet og hva jeg kan gjøre med det?
Watching you
vidarlo's Avatar
nFF Crew
nov. 2005
Kva viser lsusb -v?

Og kva viser dmesg når du plugger i chippen?
Cybergasm's Avatar
jan. 2004
Hvordan er strømforsyningen din?
Har hatt lignende problem selv, prøvde å streame fra nettet og får kun spilt av noen sekunder før nettet forsvinner helt. På routeren står det at jeg har over 70% signalstyrke.
Problemet forsvant med en gang jeg byttet strømforsyning, jeg hadde en som skulle gi 2.4A og den nye er på 2A så tipper den forrige hadde problemer med å holde korrekt spenning.
Nawesome
Provo's Avatar
nFF Crew
okt. 2006
Sitat av vidarlo Vis innlegg
Kva viser lsusb -v?
Vis hele sitatet...

Kode

Bus 001 Device 006: ID 0bda:8179 Realtek Semiconductor Corp. 
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               2.00
  bDeviceClass            0 (Defined at Interface level)
  bDeviceSubClass         0 
  bDeviceProtocol         0 
  bMaxPacketSize0        64
  idVendor           0x0bda Realtek Semiconductor Corp.
  idProduct          0x8179 
  bcdDevice            0.00
  iManufacturer           1 Realtek
  iProduct                2 802.11n NIC
  iSerial                 3 00E04C0001
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength           39
    bNumInterfaces          1
    bConfigurationValue     1
    iConfiguration          0 
    bmAttributes         0xa0
      (Bus Powered)
      Remote Wakeup
    MaxPower              500mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           3
      bInterfaceClass       255 Vendor Specific Class
      bInterfaceSubClass    255 Vendor Specific Subclass
      bInterfaceProtocol    255 Vendor Specific Protocol
      iInterface              0 
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x81  EP 1 IN
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval               0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x02  EP 2 OUT
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval               0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x03  EP 3 OUT
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval               0
Device Qualifier (for other device speed):
  bLength                10
  bDescriptorType         6
  bcdUSB               2.00
  bDeviceClass            0 (Defined at Interface level)
  bDeviceSubClass         0 
  bDeviceProtocol         0 
  bMaxPacketSize0        64
  bNumConfigurations      1
Device Status:     0x0002
  (Bus Powered)
  Remote Wakeup Enabled
Sitat av vidarlo Vis innlegg
Og kva viser dmesg når du plugger i chippen?
Vis hele sitatet...

Kode

[266205.401931] usb 1-1.5: new high-speed USB device number 7 using dwc_otg
[266205.502741] usb 1-1.5: New USB device found, idVendor=0bda, idProduct=8179
[266205.502788] usb 1-1.5: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[266205.502800] usb 1-1.5: Product: 802.11n NIC
[266205.502811] usb 1-1.5: Manufacturer: Realtek
[266205.502821] usb 1-1.5: SerialNumber: 00E04C0001
[266205.504111] Chip Version Info: CHIP_8188E_Normal_Chip_TSMC_D_CUT_1T1R_RomVer(0)
[266207.502402] MAC Address = xx:xx:xx:xx:xx:xx
[266207.505989] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Sitat av Cybergasm Vis innlegg
Hvordan er strømforsyningen din?
Vis hele sitatet...
Det er original-laderen til min gamle Samsung Galaxy S5, på 2,0 A. Om det var den som var problemet, hadde jeg forventet å se noe sånn som du beskriver, og ikke at den lister opp nettverkene med signalstyrke 0. Men takk for tips likevel.
Registrer deg for å skrive svar
Moderer