Du må være registrert og logget inn for å kunne legge ut innlegg på freak.no
X
LOGG INN
... eller du kan registrere deg nå
Dette nettstedet er avhengig av annonseinntekter for å holde driften og videre utvikling igang. Vi liker ikke reklame heller, men alternativene er ikke mange. Vær snill å vurder å slå av annonseblokkering, eller å abonnere på en reklamefri utgave av nettstedet.
  8 931
Hei!
Har fulgt denne guiden her for å få opp en Windows Server 2008 gjest på en Debian-boks.
Det eneste som avvek fra guiden var punkt 1. HVM/VMX er ikke aktivert, men dette mener jeg ikke skal ha noe å si akkurat nå (Tar jeg feil?)
I terminalen til boksen, etter å ha kjørt xm create server2008, ser jeg at det står "Started domain server2008 (id=29)".

Starter derfor opp VNC på maskinen min. Kobler til IP-adressen jeg har angitt for denne virtuelle maskinen. Jeg blir bedt om passord (Har forsøkt å fjerne passord i config, da ble jeg ikke bedt om passord. Dvs, tilkoblingen fungerer i seg selv.).
Men når jeg trykker enter etter å ha tastet passordet, popper VNC opp, for så å lukke med en gang, uten at noe som helst skjer.

Ser ikke noe særlig fornuftig i /var/log/xen/* heller, skjer ikke noe spesielt når jeg kobler til med VNC. Har også prøvd å skrive | grep vnc, men her ser jeg heller ikke noe fornuftig, bortsett fra at den loggfører når den virtuelle maskinen starter, og kjører på med vnc-konfigurasjon.

Noen ideer til hvordan jeg kan feilsøke videre?
Hvorfor i himmelens navn skal du kjøre vnc når msrdp fungerer out of the box?
Sitat av AtXbYeA Vis innlegg
Hvorfor i himmelens navn skal du kjøre vnc når msrdp fungerer out of the box?
Vis hele sitatet...
Fordi OS på serveren må installeres?
Sikkerhetsklarert
Sitat av Legevakten Vis innlegg
Starter derfor opp VNC på maskinen min. Kobler til IP-adressen jeg har angitt for denne virtuelle maskinen. Jeg blir bedt om passord (Har forsøkt å fjerne passord i config, da ble jeg ikke bedt om passord. Dvs, tilkoblingen fungerer i seg selv.)
Vis hele sitatet...
Sitat av Legevakten Vis innlegg
Fordi OS på serveren må installeres?
Vis hele sitatet...

VNC fungerer jo heller ikke om du ikke har OS installert.

Er det VNC mot hosten du egentlig sliter med?
Sitat av Pjukern Vis innlegg
VNC fungerer jo heller ikke om du ikke har OS installert.

Er det VNC mot hosten du egentlig sliter med?
Vis hele sitatet...
Ingen som har noe tro på at TS er ved sine fulle fem, skjønner jeg.

Det dreier seg om VNC-konsoll til en Xen-virtualisert Windows-server. Du kobler deg til med en VNC-klient mot dom0 - kontrolldomenet for hypervisoren - og får opp skjermbildet til en av de virtuelle maskinene - domU som det heter på Xen-lingo.

Det må settes opp i konfigurasjonsfila for domenet:
# Skru på VNC
vnc=1
# VNC-server på alle IP-adresser
vnclisten='0.0.0.0'
# Passord
vncpasswd='hemmelig'
# La Xen finne en ledig port
vncunused=0
# ...eller spesifiser display
vncdisplay=1

Deretter er det bare å koble til med f.eks. vncviewer:
vncviewer -k no -geometry 1280x960 <dom0-IP>:5901
Sitat av Fortran Vis innlegg
Ingen som har noe tro på at TS er ved sine fulle fem, skjønner jeg.

Det dreier seg om VNC-konsoll til en Xen-virtualisert Windows-server. Du kobler deg til med en VNC-klient mot dom0 - kontrolldomenet for hypervisoren - og får opp skjermbildet til en av de virtuelle maskinene - domU som det heter på Xen-lingo.

Det må settes opp i konfigurasjonsfila for domenet:
# Skru på VNC
vnc=1
# VNC-server på alle IP-adresser
vnclisten='0.0.0.0'
# Passord
vncpasswd='hemmelig'
# La Xen finne en ledig port
vncunused=0
# ...eller spesifiser display
vncdisplay=1

Deretter er det bare å koble til med f.eks. vncviewer:
vncviewer -k no -geometry 1280x960 <dom0-IP>:5901
Vis hele sitatet...
Så XEN har ingen frontend som kan tilkobles med f.eks webgui eller dedikert klient for slike operasjoner ?

Nå husker jeg hvorfor jeg jobber med Vmware.
Sist endret av AtXbYeA; 8. februar 2013 kl. 22:44.
Sitat av Fortran Vis innlegg
Ingen som har noe tro på at TS er ved sine fulle fem, skjønner jeg.

Det dreier seg om VNC-konsoll til en Xen-virtualisert Windows-server. Du kobler deg til med en VNC-klient mot dom0 - kontrolldomenet for hypervisoren - og får opp skjermbildet til en av de virtuelle maskinene - domU som det heter på Xen-lingo.

Det må settes opp i konfigurasjonsfila for domenet:
# Skru på VNC
vnc=1
# VNC-server på alle IP-adresser
vnclisten='0.0.0.0'
# Passord
vncpasswd='hemmelig'
# La Xen finne en ledig port
vncunused=0
# ...eller spesifiser display
vncdisplay=1

Deretter er det bare å koble til med f.eks. vncviewer:
vncviewer -k no -geometry 1280x960 <dom0-IP>:5901
Vis hele sitatet...
Heisann!
Det var allerede slik konfigurasjon på plass, sjekket likevel over alt. Ser ingen indikasjoner til at noe skal være galt, bortsett fra at punkt 1 i guiden jeg linket til ikke gjelder..

Jeg får koblet til, blir bedt om passord, når jeg skriver passordet, popper VNC opp for så å lukke igjen..
(ノಠ益ಠ)ノ彡┻━┻
Alphanio's Avatar
Vel prøv realvnc, thightvnc eller ultravnc. Feil versjon den du bruker ?
Sitat av Alphanio Vis innlegg
Vel prøv realvnc, thightvnc eller ultravnc. Feil versjon den du bruker ?
Vis hele sitatet...
Vel..
Det var ikke verre enn å bruke UltraVNC...
Tusen takk for meget god hjelp!