Du må være registrert og logget inn for å kunne legge ut innlegg på freak.no
X
LOGG INN
... eller du kan registrere deg nå
Dette nettstedet er avhengig av annonseinntekter for å holde driften og videre utvikling igang. Vi liker ikke reklame heller, men alternativene er ikke mange. Vær snill å vurder å slå av annonseblokkering, eller å abonnere på en reklamefri utgave av nettstedet.
  589 186013
Sitat av BigJackW Vis innlegg
Legger merke til at Q22 får IP fra lokal DHCP server ...
Hva er det som avgjør om den skal få IP fra RB4011 eller Altibox?
Vis hele sitatet...
instillinger hos aib, det er en instilling som sier om tv-vlanet skal være bridget (q22 får ip direkte fra aib) eller om det skal være routed. (q22 settes i lan og det benyttes igmp proxy)

Dersom du setter porten til q22 i acess i vlan 101 så får den ip fra aib dersom instillingene hos aib tillater det.
Sist endret av Trrunde; 11. juni 2022 kl. 16:42. Grunn: Automatisk sammenslåing med etterfølgende innlegg.
Så det er korrekt at boksen skal ha en lokal IP når det benyttes igmp proxy?
Sitat av BigJackW Vis innlegg
Så det er korrekt at boksen skal ha en lokal IP når det benyttes igmp proxy?
Vis hele sitatet...
ja
▼ ... over en uke senere ... ▼
Heisan.

Noen som vet om det er mulig og erstatte Altibox's Google Wi-FI med ASUS RT-AX58U
https://www.asus.com/Networking-IoT-...tems/RT-AX58U/

Har prøvd og tulle litt, enten har jeg internett, ellers så har jeg TV
Noen som har erfaring med å programmere mot altibox/huawei q22? Vet den har bluetooth (ble) men sliter med å finne den og sende kommandoer til den via bluetooth.
▼ ... over en uke senere ... ▼
Sitat av epicfreak Vis innlegg
Forresten, om noen har unifi dream machine (pro) og Q22 der man må bruke IP-TV vlan - kan man muligens teste ut dette scriptet:

https://github.com/fabianishere/udm-iptv

Jeg har ikke testet det selv, men ser ut som det er samme problematikk for KPN (ISP i nederland) som for Altibox.. med vlan og igmp proxy etc..

Dog ser dette ut til å bli et ikke-problem med model A av boksen - selv bruker jeg bare apple-tv altibox app nå (ikke super ideelt). Men om jeg vil bruke altibox poeng til å betale for netflix abbo ser det ut som jeg må punge ut for ny boks..
Vis hele sitatet...

Jeg kjøpte nylig en UniFi UDM pro og har samme problemet. UDM'en får link når jeg plugger inn fiberen, men den får ikke IP adresse.
Jeg bruker samme SFP modul inn i UDM'en som fulgte med Altibox hjemmesentralen (Zyxel VMG).

Jeg har forsøkt å klone mac-adressen til Altibox hjemmesentralen, og sette VLAN ID'en til 102.
Etter jeg har klonet mac-adressen får jeg ikke koblet UDM'en til hjemmesentralen lenger, så jeg må factory resette hver gang jeg skal prøve ulike instillinger.

Er det noen som har erfaringer med Altibox og UDM pro, eventuelt har forslag på hva jeg kan prøve?
Er det noen som har mistet IPv6 hos Altibox i løpet av de siste to ukene? Jeg har sjekket både private abonnement og bedriftsabonnement, og overalt hvor jeg ser så er det ingen som har IPv6 lengre, verken native eller via 6rd. Kanskje det er noe lokalt hos leverandøren, men trodde alle kjørte samme opplegget?

Har hatt fungerende IPv6 så lenge jeg har hatt altibox, så syntes det var veldig rart. Kjører egne bokser da (OpenWRT), så greit å vite om de har gjort om noe vesentlig på infrastrukturen, men IPv6 har jo lenge vært veldig plug&play...
Sist endret av h017ah; 4. juli 2022 kl. 11:35. Grunn: Automatisk sammenslåing med etterfølgende innlegg.
6rd støtten blir fjernet. Men alle privat-kundene skal ha støtte for native ipv6 via dhcpv6-pd. Bedriftskunder får vel statisk prefix, men det må nok bestilles fra bedriftssupport. Da får en statisk /48 tildeling.
Er det noen som vet om altibox filtrerer UDP? Jeg prøver å sette opp wireguard men får ikke til å connecte utenifra selv om jeg slår av firewall på min UDP Pro. Er helt blokkert, akkurat som om det er filtrert før det når min gateway.

Siden jeg ikke kan legge fiber rett i UDM (enda!) så har jeg satt kabelmodemet i bro-modus. Jeg har testet UDP port 51820 og UDP port 820. Internt connecter jeg fint, men eksternt vil den ikke. Har også prøvd å connecte med netcat fra en ekstern linux server uten å klare det. Noen som er kjent med om de har noe filter?
Sitat av corvy Vis innlegg
Siden jeg ikke kan legge fiber rett i UDM (enda!) så har jeg satt kabelmodemet i bro-modus. Jeg har testet UDP port 51820 og UDP port 820. Internt connecter jeg fint, men eksternt vil den ikke. Har også prøvd å connecte med netcat fra en ekstern linux server uten å klare det. Noen som er kjent med om de har noe filter?
Vis hele sitatet...
Er ikke noen ekspert, men jeg hadde åpnet port inn for å kunne connecte til RDP på en maskin jeg har hjemme. Det sluttet å virke for en liten stund siden, og de hadde også fjernet muligheten for portforeward på nettsidene sine.
Kontaktet så kundeservice, som fortalte at de hadde innført startet med CGN (Carrier Grade NAT), så det er da ikke lenger mulig å portforewarde/connecte utenfra.
De tilbød meg så fast ip til 89kr/mnd + 200 i etableringsavgift (som jeg skulle slippe pga jeg var ganske sur).
Vil tro det kanskje er noe liknende du er utsatt for (bromodus vil nok ikke hjelpe).
for å finne ut om en er havnet på en cgnat leveranse så kan en sammenligne resultatet på http://ip.altibox.no og http://ipadresse.no
dersom de to er forskjellige så er en nok på cgnat leveranse.

Dersom cpe står i bridge kan en også sjekke ipadressen på wan interfacet på udm pro, den vil da være innforbi følgende prefix
100.64.0.0/10 (100.64.0.0–100.127.255.255 )
https://en.wikipedia.org/wiki/Reserved_IP_addresses
Sitat av Trrunde Vis innlegg
6rd støtten blir fjernet. Men alle privat-kundene skal ha støtte for native ipv6 via dhcpv6-pd. Bedriftskunder får vel statisk prefix, men det må nok bestilles fra bedriftssupport. Da får en statisk /48 tildeling.
Vis hele sitatet...
Ja, klar over dette, men ingen svarer på det jeg spør om Kanskje du orker å sjekke hvis du har altibox? Har du mistet ipv6?
Sitat av h017ah Vis innlegg
Ja, klar over dette, men ingen svarer på det jeg spør om Kanskje du orker å sjekke hvis du har altibox? Har du mistet ipv6?
Vis hele sitatet...
jeg har altibox via Lyse ja, har fremdeles ipv6.
Sitat av Trrunde Vis innlegg
jeg har altibox via Lyse ja, har fremdeles ipv6.
Vis hele sitatet...
Har altibox via Viken både hjemme og på hytta. Har fremdeles IPv6 begge steder.
Sitat av Trrunde Vis innlegg
for å finne ut om en er havnet på en cgnat leveranse så kan en sammenligne resultatet på http://ip.altibox.no og http://ipadresse.no
dersom de to er forskjellige så er en nok på cgnat leveranse.

Dersom cpe står i bridge kan en også sjekke ipadressen på wan interfacet på udm pro, den vil da være innforbi følgende prefix
100.64.0.0/10 (100.64.0.0–100.127.255.255 )
https://en.wikipedia.org/wiki/Reserved_IP_addresses
Vis hele sitatet...
Takk for tipset. Jeg har Public IPv4 eksternt fortsatt. Flere andre ting som fungerer fint med portforward, kun UDP som feiler. Vet ikke om det kan hjelpe å spør support... Noen andre som bruker UDP forward til noe?
Fikk snakket litt med support, IPv6 hos meg hadde blitt automatisk skrudd av fra deres side med feilmeldingen "Client binding watch dog timer expired" med "abort cause: no activity", altså at det ser ut som dhcpv6-klienten på OpenWRT-boksen kanskje ikke har svart på RA-pakker som den skulle? Skal se om jeg finner ut hva som gjør det.
Support fikk fikset det, så nå er IPv6 tilbake.
Sitat av h017ah Vis innlegg
"Client binding watch dog timer expired" med "abort cause: no activity", altså at det ser ut som dhcpv6-klienten på OpenWRT-boksen kanskje ikke har svart på RA-pakker som den skulle?
Vis hele sitatet...
Er ingen ack på RA. Og så vidt jeg vet så annonserer heller ikke Altibox noe prefix via RA.

Dette høres mer ut som en feilkonfigurasjon av DHCPv6-klienten. Virker ikke som den fornyer leasen som den skal.
Jeg sliter litt med multicast på Altibox og Mikrotik...

Model A bosken går i IPTV-modus og begynner å spille av kanalen men stopper etter en liten stund (30sek). Så etter en litt lengre tid (ca 3-4min) begynner den å spille fra kanalen og jeg kan se at IGPM-proxy sender ut pakker og "live-tv" virker som det skal.

Den fortsetter så å spille av kanalen helt fint til jeg skifter kanal. Da er det samme greia, stopper for så å fortsette etter en stund.

Noen som har peilig på hva det kan være?

Bruker RuterOS 7.4 og mer eller mindre oppsettet til Trrunde fra github.
Sist endret av mr.mulet; 26. juli 2022 kl. 20:51.
▼ ... noen uker senere ... ▼
Etter god hjelp fra denne tråden har jeg brukt en Mikrotik CRS106-1C-5S i stedet for Altibox-routeren. Det fungerer fint, bortsett fra at ca. en gang i døgnet faller linja fra Altibox ut, link down, i 1-2 minutter før den er oppe igjen.

Det er helt sikkert noe åpenbart jeg har oversett. Hva kan denne "link down" skyldes?
▼ ... over en uke senere ... ▼
Jeg mottar snart en Mikrotik RB5009UPr+S+IN i posten, og har begynt så smått å se på oppsettet. Må innrømme at jeg finner endel av det forvirrende, har noen spørsmål rundt det:

I oppsettet fra trrunde som ligger på Github ser jeg disse to linjene:

Kode

/interface bridge
add admin-mac=74:4D:28:27:8E:D0 auto-mac=no comment=defconf igmp-snooping=yes name=bridge-lan
Hvor kommer den MAC-adressen fra? Kan jeg autogenerere den selv, eller må jeg sniffe den fra hjemmesentralen min på noe vis?

Stusser også på denne linjen:

Kode

/ip dhcp-client option
add code=60 name=vendor-class-identifier value=0x46542D503334313042
Hva er det for noe?

Jeg ser også at den lokale IP-adresserangen

Kode

10.11.12.0/24
går igjen. Jeg regner med at det går helt greit for meg å endre den til 10.0.0.0/24 alle steder?
mac adressen på bridge interfacet - autogenerert

dhcp opsjon 60 - gir denne til aib dhcp server for at jeg skal late som jeg er en godkjent klient for å få opsjoner via dhcp for hvilke subnet som skal routes via vlan 101

10.11.12.0/24 - mitt lokale prefix på lan, sett det til noe som passer inn i ditt eget oppsett.
Sitat av Trrunde Vis innlegg
mac adressen på bridge interfacet - autogenerert

dhcp opsjon 60 - gir denne til aib dhcp server for at jeg skal late som jeg er en godkjent klient for å få opsjoner via dhcp for hvilke subnet som skal routes via vlan 101

10.11.12.0/24 - mitt lokale prefix på lan, sett det til noe som passer inn i ditt eget oppsett.
Vis hele sitatet...
Takk, da var alt ganske klart.

Gleder meg som en unge til jeg mottar Mikrotik'en, skal bli deilig å endelig bli kvitt den forferdelige Altibox-hjemmesentralen.
Deler en morsom(?) erfaring jeg gjorde i går i tilfelle det hjelper andre ifm feilsøking en gang...

Har Q22-deoderen og opplevde plutselig at linjær-TV ikke lenger virket. Åpenbar multicast-feil der unicast-streaming ga noen sekunder med bilde etter kanalbytte før skjermen gikk i svart. Skal ikke dra ut hele den unødvendig lange og kjedelige debug-historien:

Reboot av switchen i TV-benken løste problemet.

Switchen svarte ikke på management-adressen sin før jeg rebootet den. Denne feilen blokkerte tydeligvis også IGMP., muligens fordi den ikke hadde noen source-adresse for sine egne IGMP-queries? Aner ikke hvordan feilen oppstod. Muligens relatert til strømukobling dagen før, uten at jeg helt forstår hvorfor det skulle gi en slik effekt. Eller så er det alderen som begynner å gjøre seg gjeldende. Switcen ble kjøpt i 2009. Første gang jeg opplever en slik feil på den
▼ ... noen uker senere ... ▼
Noe har visst endret seg ifm TV VLAN eller tjenester denne uken? Gjelder Q22 dekoder hos Viken

Jeg har alltid likt å ha TV-dekoderen på et eget VLAN. Ser absolutt null grunn til å slippe den inn på mitt hjemmenett. Det var jo veldig enkelt i gamle dager, der vi bare kunne swithce VLAN 101 direkte til dekoderen. Men også etter at vi måtte ha en "hjemmesentral" imellom så har jeg fortsatt å route VLAN 101 til et eget dekoder-VLAN, uten tilgang til VLAN 102 eller noe annet utenom VLAN 101. Dette har funket helt greit, inkludert alle mulige streaming-tjenester på dekoder. Vel, alle jeg har testet ihvertfall.

Men i går virket plutselig ikke Viaplay lenger. Andre streaming-tjenester som f.eks NRK virket som før. Bare ikke Viaplay. Den stod bare og snurret på timeglass-sirkelen sin.

Litt snooping i dag, og jeg så at problemet var relatert til en Fastly-adresse (151.101.239.9) som tydeligvis ikke er rutet på VLAN 101 hos Altibox. Vet ikke hva som har endret seg. Mulig det er Viaplay som har endret noe, eller så er det kanskje bare tilfeldige endringer i CDN. Litt av poenget med CDN er jo nettopp at tjenester og ip-adresser er nokså uavhengige av hverandre, og at adressene endrer eg ved behov i nettet.

Uansett, jeg byttet ut default-ruta på dekoder-VLANet mitt med en rute som går ut VLAN 102 og da virker Viaplay igjen. Så det er tydeligvis slutt på at Altibox tilbyr tilstrekkelig med Internett-ruting via VLAN 101 til at dekoderne klarer seg med kun dette.

Fremdeles litt usikker på om det riktige nå er å rute kun multicast via VLAN 101 og all unicast via VLAN 102. Foreløpig har jeg valgt å beholde de rutene som DHCP-serveren på VLAN 101 deler ut, med unntak av default (veldig uhensiktsmessig at DHCP-serveren inkludert den, forresten).

For tiden er det bare disse prefiksene hos meg:

Kode

10.133.0.0/16 
84.234.204.0/23 
84.234.250.128/25 
172.21.0.0/16 
213.167.98.0/26
Er vel ikke usannsynlig at det er nødvendig å rute 10.133.0.0/16 og 172.21.0.0/16 til VLAN 101 ihvertfall. Har ikke testet. Og da kan jeg like gjerne gå ut fra at DHCP-serveren vet hva den gjør mht de ande 3 prefiksene.

Dette er det som nå virker for meg mht TV:

default => VLAN 102
multicast (igmpproxy) => VLAN 101
prefiksene listet ovenfor => VLAN 101
Argh! Men adressen til DHCP-serveren på TV-VLANet er selvsagt ikke med i noen av prefiksene de router den veien. Så dermed virker ikke DHCP fornying lenger uten at vi manuelt legger til en ekstra rute for den. Det er visst om å gjøre å lage ting mest mulig herkete.
Jeg sliter med q22 dekoderen min nå. Har kjørt pfsense i flere år uten problemer. Hva er rute for dhcp server ?

Det var enklere enn jeg trodde å fikse.. "Use non-local gateway" Så var alt i orden
Sist endret av janolov; 29. september 2022 kl. 11:57. Grunn: Automatisk sammenslåing med etterfølgende innlegg.
▼ ... over en uke senere ... ▼
Jeg har en morsom problemstilling jeg håper noen kan hjelpe meg med.

Jeg har en seedbox med plex på altibox, og for alt jeg eier og har, får jeg ikke den til å kjøre smooth selv når speedtest registrerer at jeg får 350mbit ned. En kompis som har samme ISP, router og oppkobling, med halvparten av hastigheten får det til å kjøre med en gang. Jeg har jobbet med support i 10+ år og aner ikke hva dette kan være - noen som har noen ideer?
▼ ... noen uker senere ... ▼
Hei folkens!

Jeg har nylig satt opp en MikroTik RB3011 i tråd med @Trrundes konfig fra https://github.com/trrunde/routercon...rb4011-altibox . Fiber'n fra Altibox er satt rett inn i SFPen, og MikroTiken får offentlig IP på VLAN 102. Vanlig surfing fungerer fint.

Jeg får imidlertid ikke tildelt IP på VLAN 100 eller 101. Er noen kjent med dette problemet?

Når jeg debug-logger ser det ikke ut som om jeg får et eneste svar på noen av DHCP-forespørslene. Torch viser at det er innkommende trafikk på VLAN101-grensesnittet, så jeg har tro på at jeg har satt opp VLAN-grensesnittet riktig.

(PS: Har foreløpig ikke satt opp IPv6, fordi jeg vil holde antall feilkilder til et minimum. Håper ikke det er dette som klusser til for meg her?)

Kode

[admin@MikroTik 126 RB3011] > /export
# oct/23/2022 21:52:45 by RouterOS 7.6
#
# model = RB3011UiAS
/interface bridge
add igmp-snooping=yes name=bridgeLAN
/interface vlan
add interface=sfp1 name=sfp1-vlan100-voip vlan-id=100
add interface=sfp1 name=sfp1-vlan101-tv vlan-id=101
add interface=sfp1 name=sfp1-vlan102-internet vlan-id=102
/interface list
add name=interfaceListWAN
add exclude=interfaceListWAN include=all name=interfaceListLAN
/ip dhcp-client option
add code=60 name=vendor-class-identifier value=0x46542D503334313042
/ip dhcp-server option
add code=43 name=q22 value="'Altibox-TMS-Server-Address:https://tmc.services.altibox.net:37020/acs'"
/ip dhcp-server option sets
add name=set1 options=q22
/ip pool
add name=poolLAN ranges=10.0.126.20-10.0.126.250
/ip dhcp-server
add address-pool=poolLAN dhcp-option-set=set1 interface=bridgeLAN lease-time=2d name=DHCPserverLAN
/interface bridge port
add bridge=bridgeLAN ingress-filtering=no interface=interfaceListLAN
/interface list member
add interface=sfp1 list=interfaceListWAN
add interface=sfp1-vlan100-voip list=interfaceListWAN
add interface=sfp1-vlan101-tv list=interfaceListWAN
add interface=sfp1-vlan102-internet list=interfaceListWAN
/ip address
add address=10.0.126.1/24 interface=bridgeLAN network=10.0.126.0
/ip dhcp-client
add add-default-route=special-classless default-route-distance=100 dhcp-options=vendor-class-identifier disabled=yes interface=sfp1-vlan100-voip use-peer-dns=no use-peer-ntp=no
add add-default-route=special-classless default-route-distance=100 dhcp-options=vendor-class-identifier interface=sfp1-vlan101-tv use-peer-dns=no use-peer-ntp=no
add dhcp-options=vendor-class-identifier interface=sfp1-vlan102-internet use-peer-ntp=no
/ip dhcp-server matcher
add address-pool=poolLAN code=43 name=q22 server=DHCPserverLAN value="'Altibox-TMS-Server-Address:https://tmc.services.altibox.net:37020/acs'"
/ip dhcp-server network
add address=10.0.126.0/24 dhcp-option=q22 dns-server=10.0.126.1 gateway=10.0.126.1 netmask=24
/ip firewall address-list
add address=10.0.126.0/24 list=adrLAN
/ip firewall filter
add action=accept chain=input connection-state=established,related
add action=accept chain=input in-interface=sfp1-vlan101-tv protocol=igmp
add action=accept chain=input in-interface=sfp1-vlan101-tv
add action=accept chain=input protocol=igmp
add action=accept chain=input in-interface-list=interfaceListLAN src-address-list=adrLAN
add action=accept chain=input in-interface-list=interfaceListLAN
add action=drop chain=input connection-state=invalid
add action=drop chain=input
add action=drop chain=forward connection-state=invalid disabled=yes
add action=fasttrack-connection chain=forward connection-state=established,related hw-offload=yes
add action=accept chain=forward connection-state=established,related
add action=accept chain=forward in-interface-list=interfaceListLAN out-interface-list=interfaceListWAN
add action=accept chain=forward in-interface=sfp1-vlan101-tv
add action=drop chain=forward
/ip firewall nat
add action=masquerade chain=srcnat ipsec-policy=out,none out-interface=sfp1-vlan102-internet
add action=masquerade chain=srcnat out-interface=sfp1-vlan101-tv
add action=masquerade chain=srcnat out-interface=sfp1-vlan100-voip
/routing igmp-proxy
set quick-leave=yes
/routing igmp-proxy interface
add alternative-subnets=0.0.0.0/0 interface=sfp1-vlan101-tv upstream=yes
add interface=bridgeLAN
Sist endret av Tell; 23. oktober 2022 kl. 23:11.
Sitat av Tell Vis innlegg
Hei folkens!

Jeg har nylig satt opp en MikroTik RB3011 i tråd med @Trrundes konfig fra https://github.com/trrunde/routercon...rb4011-altibox . Fiber'n fra Altibox er satt rett inn i SFPen, og MikroTiken får offentlig IP på VLAN 102. Vanlig surfing fungerer fint.

Jeg får imidlertid ikke tildelt IP på VLAN 100 eller 101. Er noen kjent med dette problemet?
Vis hele sitatet...
… og for å dele løsningen: Jeg klonet MAC-adressen fra den originale Altibox-boksen inn på SFP-grensesnittet, og da fikk jeg med en gang IP! Konfigurasjonen ser ut til å fungere godt.
▼ ... noen uker senere ... ▼
Hei
Skal flytte inn i nytt hus nå, der blir det Homenet som skal levere fiber. Homnet levere fra 10Gbit/s å ned, jeg har bestilt 2.5Gbit/s siden jeg betaler mindre for det enn jeg gjorde for 500 fra Altibox. Men det betyr at man må tenke litt mer på utstyret man setter inn så det støtter hastigheten man har.
Noen som har forslag på router som støtter 10.Gbit, jeg tror den hastigheten kommer til og bli mer vanlig i hjem fremover.
10gb irelevant,, bare hvis du har M.2 i raid 0 ,, pcie-5 nvme, som skal komme
Sitat av Oluf77 Vis innlegg
10gb irelevant,, bare hvis du har M.2 i raid 0 ,, pcie-5 nvme, som skal komme
Vis hele sitatet...
Du tar litt feil der. Vi ser mer og mer 10Gb komme, i usa pushe de ut 10Gb for 200.kr i mnd for hjemme bruk. Skrive hastigheten på NVME spiller ingen rolle når det gjelder og laste inn webside da dette blir gjort i minne på maskin. Vi snakker også om bits og ikke bytes. Går 8 bits i en byte så vis du har en 1Gb linje i dag så tilsvarer det 125mb/s som de fleste moderne disker takler. På en 10Gbit linje vil du kunne oppnå en hastighet på 1.25gb/s som betyr vis du har som de fleste en nvme disk i din maskin kan du se nedlasting fra 300-800mb/s etter hvor rask disk du har. Mange har i dag NAS hjemme med 10Gb nic, raske disker med nvme buffer som gjør at du kan jobbe på filer lokalt på NASen uten å måtte drive og føre filer frem og tilbake. Å redigere en video eller bilde direkte på NASen sparer tid og gjør ting mye enklere. Har du en 10Gb linje kan du også gjennom switchen dele ut 1Gb til ulike klienter som da ville kunne bruke hele sin 1Gb bånd bredde på nett å responsen vil bli raskere. Nå har jeg bare bestilt 2.5Gb hastighet 312mb/s linje men med mulighet for oppgradering i fremtiden. Å alle mine disker takler mer enn 312mb/s. Men jeg ønsker å være klar for fremtiden derfor ønsker jeg 10Gb hjemme nettverk.
▼ ... over en måned senere ... ▼
Og så var på'n igjen med feil på IPv6 etter planlangt vedlikeholdsarbeid i nettet...

Hadde varslet vedlikehold i natt. Fikk ny IPv4-adresse etter at det var ferdig. Men DHCPv6 har feilet konsekvent siden arbeidet startet.

Ser at jeg får "UnspecFail" fra en for meg ukjent DUID, eksakt 240 sekunder etter første solicit og deretter en gang i blant med 4-6 minutters mellomrom. At dette svaret kommer såpass sent tolker jeg som at feilen ligger i nettet. Dersom de fant noe galt ved min solicit så ville jo svaret kommet umiddelbart. Og når svaret kommer fra en ukjent DUID så er det fristende å anta at dette er en "proxy" elns som ikke får kontakt med sin upstream server. DUIDen er også av typen DUID-LL, som neppe brukes av noen server eller annet utstyr med lagringmedia (Altibox' server har pleid å bruke DUID-LLT). Mest sannsynlig svarer første ruter jeg treffer som best den kan når den ikke får kontakt videre med sin konfigurerte DHCPv6-server.

I desperasjon forsøkte jeg å sende release for det forrige prefikset jeg hadde både til den DUIDen som tildelte det og til den ukjente DUIDen. I begge tilfeller får jeg umiddelbart svar med status "NoBinding". Men hvis teorien ovenfor er korrekt så er det nok "proxyen" som svarer i begge tlfeller.

Noen forslag til triks som kan prøves utover å kontakte kundeservice (som er forsøkt, men jeg har naturlig nok ingen forventninger om at det løser problemet)?

DHCPv6-pakkene jeg får tilkake ser slik ut:

Kode

DHCPv6
    Message type: Advertise (2)
    Transaction ID: 0xcc81a6
    Server Identifier
        Option: Server Identifier (2)
        Length: 10
        DUID: 00030001e4c7224c0e57
        DUID Type: link-layer address (3)
        Hardware type: Ethernet (1)
        Link-layer address: e4:c7:22:4c:0e:57
    Client Identifier
        Option: Client Identifier (1)
        Length: 14
        DUID: 0001000113dc484e0015171e5e34
        DUID Type: link-layer address plus time (1)
        Hardware type: Ethernet (1)
        DUID Time: Jul 23, 2010 14:32:14.000000000 CEST
        Link-layer address: 00:15:17:1e:5e:34
    Status code
        Option: Status code (13)
        Length: 2
        Status Code: UnspecFail (1)

DHCPv6
    Message type: Reply (7)
    Transaction ID: 0x6351e7
    Client Identifier
        Option: Client Identifier (1)
        Length: 14
        DUID: 0001000113dc484e0015171e5e34
        DUID Type: link-layer address plus time (1)
        Hardware type: Ethernet (1)
        DUID Time: Jul 23, 2010 14:32:14.000000000 CEST
        Link-layer address: 00:15:17:1e:5e:34
    Server Identifier
        Option: Server Identifier (2)
        Length: 10
        DUID: 00030001e4c7224c0e57
        DUID Type: link-layer address (3)
        Hardware type: Ethernet (1)
        Link-layer address: e4:c7:22:4c:0e:57
    Status code
        Option: Status code (13)
        Length: 2
        Status Code: NoBinding (3)

DHCPv6
    Message type: Reply (7)
    Transaction ID: 0x8c5598
    Client Identifier
        Option: Client Identifier (1)
        Length: 14
        DUID: 0001000113dc484e0015171e5e34
        DUID Type: link-layer address plus time (1)
        Hardware type: Ethernet (1)
        DUID Time: Jul 23, 2010 14:32:14.000000000 CEST
        Link-layer address: 00:15:17:1e:5e:34
    Server Identifier
        Option: Server Identifier (2)
        Length: 14
        DUID: 0001000119af6056001a4aa88e40
        DUID Type: link-layer address plus time (1)
        Hardware type: Ethernet (1)
        DUID Time: Aug 27, 2013 15:04:22.000000000 CEST
        Link-layer address: 00:1a:4a:a8:8e:40
    Status code
        Option: Status code (13)
        Length: 2
        Status Code: NoBinding (3)
▼ ... noen uker senere ... ▼
Hei,

Ser ut som det er mye hjelpsomme folk med mye kunnskap i tråden. Håper dere kam hjelpe meg med valg av utstyr.
I dag har jeg en zyxel hjemmesentral med model a tv box. bruker hjemmesentralen sammen med billig switch og airties mesh.
Dette oppsettet fungerer ok for meg i dag men har lyst til æ bytte utstyret for å lære mer om nettverk. Har ikke noe i mot å knote litt.

Jeg har en MT CSS326-24G-2S+RM switch men jeg trenger en router.
fordel om routeren er rackmonterbar.
Bør jeg kjøpe en router med sfp eller kan jeg like gjerne bruke sfp i switchen så koble igjennom routeren?
max budsjett 3000 men jo billigere jo bedre så lenge routeren dekker mitt behov.

Har sett på disse :
RB4011IGS+RM
EdgeRouter ER-4 + racksett
RouterBOARD RB2011iL-RM

Er dette produkter som passer meg? hvilken ville dere gått for?
andre forslag?
Sist endret av Speb1a; 3 uker siden kl. 18:43.
https://community.ui.com/questions/W...b-54eb251b904c

Bruker selv en RB4011, men jeg vil tro du sliter med å få fatt i utstyr for tiden.
@Trrunde , takker for svar.

Jeg fant også ut det etterhvert å endte opp med å kjøpe en brukt usg-pro-4 på finn.
Ser det er langt fra siste skrik men håper og tror det vil holde til mitt bruk.
▼ ... noen uker senere ... ▼
Da har jeg lest en del her, og kranglet selv med mitt oppsett og blir nesten nødt til å spørre/lufte for idéer.

Jeg får Altibox fra Istad Fiber. Har en FMG som står i bromodus, men skal få tak i en SFP for å omgå den driten der helt. Fra FMG går nettet videre til WAN-porten jeg har satt på en OPNSense-boks. WAN er satt til DHCPv6 med disse instillingene:

Så har jeg satt LAN til "Track Interface" og valgt en prefix ID (0x20 i dette tilfellet), og dette ser ut til å gi meg kontakt via v6 til omverden:

So far so good. Min problemstilling, er at jeg vil ha ::1 som ip på default gateway (akkurat nå er den :d267:e5ff:fee7:dc92, veldig lett å huske), og jeg vil ha min egen interne DHCPv6 server for å delegere (og reservere) v6 til klienter. Såvidt jeg klarer å se, så er dette ikke mulig med "track interface" for da får jeg DHCPv6 fra altibox eller noe sånt? Uansett så har jeg prøvd å sette statisk IPv6 på LAN uten noe resultat, og DHCPv6 Relay funker ikke i det hele tatt såvidt jeg kan se.

Hardware jeg har er en Cisco Catalyst 3850 som "core" switch og OPNSense som brannmur og router til internett. Jeg har hatt litt lyst til å leke med MikroTik, er det noe som kan løse problemene mine, enten med det utstyet jeg allerede har eller noe jeg burde skaffe meg (holder meg konsekvent unna Ubiquiti)?
@MrMrRubic har også OPNsense til inet med "track interface", med DHCPv6-PD og /56 og det funker men bare hvis klokka er riktig synkronisert. Og enn så lenge det avhenger av IPv4-aksess så er det en teit løsning
men så lenge det er stabilt nok så skal iikke jeg klage. Regner med (litt tungvindt å måtte skrive inn )du kan skrive i shell f.eks:
ifconfig <lan_intf> inet6 2a01:79X:XXXX:XXXX::1 prefixlen 64
og ULA-adresser f.eks ifconfig <lan_intf> inet6 fc01::1 prefixlen 64
og hvis du skal fjerne en addr. meed -alias på slutten. Hvis ikke så er det jo Link Local (fe80)-adresser som brukes for gateway
Mener å huske at det er en setting som "Allow manual adjustment of DHCPv6 and RA", Services/RA sett til Off på LAN. Så sette opp en DHCPv6 tjener på et /64 som er innenfor den /56 range som du får fra altibox
Hei, noen med Mikrotik router som har oppgradert til v7? Ser at Multicast ikke er støttet lenger, vil det by på problemer med Q22 dekoder og eget vLan?