Du må være registrert og logget inn for å kunne legge ut innlegg på freak.no
X
LOGG INN
... eller du kan registrere deg nå
Dette nettstedet er avhengig av annonseinntekter for å holde driften og videre utvikling igang. Vi liker ikke reklame heller, men alternativene er ikke mange. Vær snill å vurder å slå av annonseblokkering, eller å abonnere på en reklamefri utgave av nettstedet.
  4 735
Jeg har en gammel maskin som jeg tenkte å gjøre om til en gaming PC.
Det er en HP Proliant DL380 tror jeg.

Husker ikke hva det heter, men tror det kalles backplane-kort. Jeg har fjernet dette kortet ettersom det ble svidd. Jeg hadde likevel en raid-kontroller jeg kunne putte i PCIe-sloten, så det gjorde jeg.

Problemet er at dette medfører at harddiskene ikke har strøm, fordi de får i utgangspunktet strøm fra det backplane-kortet. Nå har de kun sata-tilkobling til raid-kontrolleren. Jeg har bekreftet at raid-kontrolleren fungerer og oppdager harddiskene, ettersom jeg koblet harddiskene til en ekstern strømforsyning for å teste.

Har derfor sett på strømkabelen som kommer fra hovedkortet til backplane-kortet, og vurderer å leke litt med den for å få strømmen jeg trenger. Det er denne.

Kontakten på dette kortet ligner på kontakten som kobles til PSU-en når man har en sata-strømkabel. Dette bildet viser hvilken kontakt jeg sikter til. Altså kontakten helt til høyre.
https://ae01.alicdn.com/kf/HLB1JJ26X...s-Platinum.jpg

Tenkte derfor å kanskje kutte kontaktene bort og koble lederne slik at sata-strømkontaktene får strøm fra kabelen som egentlig skal inn i backplane-kortet. Det er bare det at kontakten til backplane-kortet er identisk, men mindre i fysisk størrelse.
Det gjorde at jeg ville undersøke med et multimeter før jeg i det hele tatt gjorde noe her.

Resultatet ble som følger:

Det betyr at jeg må splitte opp den ene positive 12v-lederen og unngå å bruke den ene jord-lederen for å få det som jeg vil.
Noen som vil protesere?

Næ. Jeg gjorde det, og det gikk vel cirka bra? Diskene fikk strøm og hele pakka, men ingen av dem begynte å spinne opp. SSD-ene begynte å lukte svidd, så jeg tenker at dette kanskje ikke ga harddiskene noe signal om å starte opp, og samtidig ikke hadde noen funksjon for å sjekke hvor mye strøm disken vil ha. SSD-ene overlevde heldigvis.

Eller så var det en leder som ikke ble helt riktig. Samma det, jeg gir faen i det nå, jeg fikk det til å fungere uten dette.

Tips: Ikke gjør dette.
Sist endret av Offentligfyr; 3 uker siden kl. 01:48. Grunn: Automatisk sammenslåing med etterfølgende innlegg.
▼ ... over en uke senere ... ▼
Jeg er ikke helt med på åssen du har koblet, men SATA skal ha 3.3V og 5V også, ikke bare 12V.
https://pinoutguide.com/Power/sata-power_pinout.shtml
Trigonoceps occipita
vidarlo's Avatar
Donor
Sitat av GalFisk Vis innlegg
Jeg er ikke helt med på åssen du har koblet, men SATA skal ha 3.3V og 5V også, ikke bare 12V.
https://pinoutguide.com/Power/sata-power_pinout.shtml
Vis hele sitatet...
Pins 1, 2, and 3 are optional as well, as evidenced by some adapter cables that connect the drives to older PSUs. These are usually Y-adapters that have the four-pin drive connector on the other end. Currently, SATA drives rarely use 3.3 volts. That may be because there are too many people using adapters so the drive makers don't want the headaches which come with using 3.3 volts. But in the future, 3.3 volt drives may become common so you need to be careful when using SATA power cables which don't implement 3.3 volts.
Vis hele sitatet...
Det står altså på sida du lenka til.

Så langt har eg ikkje treft på SSDer eller harddisker som nekter å fungere uten 3.3V.
Trådstarter
9 0
Jeg tror ikke det er koblingen som slo feil, men det at 3.3 og 5v ikke blir levert fra kontakten jeg koblet det til. Kun 12v. Jeg tror at backplane-kortet ville ha gitt korrekt volt ut fra sata-portene som er på den. Kortet i seg selv blir forsynt med 12v.
Aha, da er jeg med.