Du må være registrert og logget inn for å kunne legge ut innlegg på freak.no
X
LOGG INN
... eller du kan registrere deg nå
Dette nettstedet er avhengig av annonseinntekter for å holde driften og videre utvikling igang. Vi liker ikke reklame heller, men alternativene er ikke mange. Vær snill å vurder å slå av annonseblokkering, eller å abonnere på en reklamefri utgave av nettstedet.
  2351 809565
Sitat av guleman Vis innlegg
Tror ikke det.

Tror de kommer untagged fra FMG så da kan du tagge de med valgfritt vlan.

Har ikke gjort det selv så kan ikke garantere noe, kjører via edgerouter.
Vis hele sitatet...
Ok, takk for hjelpen.

Men nå skjedde det noe rart. Jeg konfigurerer systemet med kun internett koblet til fra FMG, altså ikke koblet til tv-signalene fra FMG. Tv-signalene går direkte fra FMG og inn i q22. Likevel starter tv-sendingene å hakke etter et par sekunder på tv'en.

Noen som vet hva som skjer her? Kan innstillingene i Unifi påvirke FMG'en som står i bridge mode?
Burde ikke gjøre det.
Prøvd å restarte FMG?
Ville hørt med altibox support/chat evt. Det skal jo fungerer knirkefritt egentlig..
Sitat av guleman Vis innlegg
Burde ikke gjøre det.
Prøvd å restarte FMG?
Ville hørt med altibox support/chat evt. Det skal jo fungerer knirkefritt egentlig..
Vis hele sitatet...
Jeg restartet fmg'en, og da fungerte det igjen etter en stund. Uansett merkelig.

Altibox support ville forøvrig ikke svare på om signalene fra fmg i bridge mode var tagged eller untagged. Det eneste han kunne si var at signalene bruker IGMP Snooping/Proxy funksjonalitet.

Noen som vet hva det betyr?
Alle porter på lan siden av FMG er utagget, både ved bridge mode og routed mode.
Hei!

Jeg sitter å drar ut det lille håret jeg har igjen på topplokket. Kjøpte 3 stk standalone mesh routere av merket Amplifi HD for å ha en i hver etasje via backhaul, jeg har da selvfølgelig kablet til hver etasje. Men problemet starter allerede ved første router i teknisk rom hvor altibox fiber kommer inn, jeg har satt fmg i bridge men får "no internet Connection" i display på Amplifi'en og feil ved ipv4 samt dns krøll. Har prøvd å endre dns uten hell. Satte så FMG tilbake til router modus og Amplifi til bridge da jeg kan overleve uten gjestenettverk etc. men også i denne situasjonen er problemet det samme... Er det noen der ute som har fått dette til å fungere? Har for øvrig en Asus GT-AC5300 som fungerer strålende, men denne er ikke akkurat wife aproved å hengende på veggen...
Sist endret av s4lem0nsen; 7. april 2019 kl. 20:14. Grunn: Automatisk sammenslåing med etterfølgende innlegg.
▼ ... noen uker senere ... ▼
Hei!
Zyxel FMG3542

Jeg skal sette opp WOL på en maskin stående på nettverket, alt fungerer som det skal ett minutt eller to etter jeg har slått av maskinen jeg har satt opp WOL på.
WOL fungerer ikke lenger når hjemmesentralen flusher ARP så IP og MAC -adresse på target maskinen blir slettet fra hjemmesentralen.

Normalt så kan man vel manuelt legge til et ARP entry via telnet, men hjemmesentralen er dessverre i mine øyne langt fra normal.

Har noen en fix for dette?

På forhånd takk!
Har ett lite spørsmål her. Hvis en ser litt på bildet under så gjelder det den øverste linjen, den som har destination 0.0.0.0/0. Har lest tidligere her i tråden at den egentlig ikke skal være der? Men jeg har den i alle fall. Er det slik at den skal vekk?

Det er default route. Du skal stortsett alltid ha default route, om du vil ha internett.
Internett er jo kjekt å ha :-) Takk for den hurtige tilbakemeldingen :-)
Sitat av B1ack Vis innlegg
Hei. Har noen her erfart å miste tilgang til både TV og Internet etter å ha prøvd å koble opp egen router med fiber rett i SPF port?

Har brukt ett par dager på å konfigurere Mikrotic 3011 og plutselig nå i dag mens jeg drev å prøvde å konfigurere flere nettverk på ruteren så mista jeg IP lease på VLAN101 så TV signalet forsvant.

Etterpå kobla jeg opp orginale Altibox utstyret med fiberkonverter og Zyxel routeren uten at det hjalp. Automatisk utestegning dersom dem plukker opp "uønsket" aktivitet med uorginalt utstyr?

Hei. Har noen her erfart å miste tilgang til både TV og Internet etter å ha prøvd å koble opp egen router med fiber rett i SPF port?

Har brukt ett par dager på å konfigurere Mikrotic 3011 og plutselig nå i dag mens jeg drev å prøvde å konfigurere flere nettverk på ruteren så mista jeg IP lease på VLAN101 så TV signalet forsvant.

Etterpå kobla jeg opp orginale Altibox utstyret med fiberkonverter og Zyxel routeren uten at det hjalp. Automatisk utestegning dersom dem plukker opp "uønsket" aktivitet med uorginalt utstyr?
Vis hele sitatet...
Fikk du noen gang svar fra Altibox vedr. dette. Jeg skulle teste fra fungerende EdgeRouter med å koble fiberen tilbake i FMG-en. Den får kontakt med altibox, gir ip (både i og uten bridge mode), men virker til FMG er blokkert etter jeg har brukt uoriginalt utstyr ved at en ikke får pinget/kommet forbi deres gateway.

Har snakket med Altibox i flere timer i dag, og de sier den er koblet til (jeg får pinget infrastrukturen til altibox), men ikke noe internett, alt stopper i deres gateway.

Kobler jeg fiberen tilbake i edgerouteren fungerer alt igjen.

Så ja, virker til Altibox blokkerer folk som bruker tredjepartsutstyr, med mindre du klarte å finne ut hvordan en løser det?
Ett kjapt spørsmål som jeg håper noen kanskje kan svare på...
Jeg har en public ip fra Viken Fiber (Altibox) men sliter med å få denne til å virke via DHCP. I ett forsøk på å sette denne statisk så lurer jeg på om noen vet hva som er "default" subnet ifm fast ip-adresse hos Viken Fiber/Altibox.. Kundeservice har nemlig overhodet ingen ide om hva jeg egentlig spør om...
Sist endret av TommyH; 2. mai 2019 kl. 19:45. Grunn: Automatisk sammenslåing med etterfølgende innlegg.
Sitat av TommyH Vis innlegg
Ett kjapt spørsmål som jeg håper noen kanskje kan svare på...
Jeg har en public ip fra Viken Fiber (Altibox) men sliter med å få denne til å virke via DHCP. I ett forsøk på å sette denne statisk så lurer jeg på om noen vet hva som er "default" subnet ifm fast ip-adresse hos Viken Fiber/Altibox.. Kundeservice har nemlig overhodet ingen ide om hva jeg egentlig spør om...
Vis hele sitatet...
de er ingen default for dette. Det vil uansett ikke virke om du setter ipadresse statisk, det trengs dhcp for å få bng sesjon på plass.
Hei.
Har kjørt uten Zyxel-boxen lenge, men nå har de gått over fra Altibox til Get som tjenesteleverandør her jeg bor.
etter det har jeg måtte koble opp igjen zyxelen.
Er det noen som har anelse om hvordan man setter opp mot Get?
Sist endret av L.D Oppholdsnes; 6. mai 2019 kl. 20:10. Grunn: Automatisk sammenslåing med etterfølgende innlegg.
Sitat av L.D Oppholdsnes Vis innlegg
Hei.
Har kjørt uten Zyxel-boxen lenge, men nå har de gått over fra Altibox til Get som tjenesteleverandør her jeg bor.
etter det har jeg måtte koble opp igjen zyxelen.
Er det noen som har anelse om hvordan man setter opp mot Get?
Vis hele sitatet...
Get bruker GPON. Du må bruke get sitt utstyr, men du kan sikkert settje det i bridgemode e.l.
Sitat av vidarlo Vis innlegg
Get bruker GPON. Du må bruke get sitt utstyr, men du kan sikkert settje det i bridgemode e.l.
Vis hele sitatet...
Jeg kan ikke si det helt sikkert, men ikke sikkert get bruker gpon overalt. Tafjord leverte altibox tjenester tidligere og da var det ikke gpon i hvertfall, nå har Tafjord skiftet til Get og jeg vil ikke tro de tar i bruk gpon når det allerede eksisterer fiberinfrastruktur der uten gpon.
Hadde Tafjord ja, fungerte en stund etter de hadde byttet til Get, men nå i forrige uke så døde det, men med Zyxelen så fungerer det nå..
spørs om de har endret innstillingene på boksen og gjort om infrastruktur da..
IT-Konsulent
Er det noen som har fått satt fast ip på enheter på nettverket sitt via altibox hjemmesentral? Det er den hvite skiten, Modell FMG3542

Trenger dette da jeg har et trådløst kamera som må ha portvidrekobling....... Men kameraet i seg selv støtter ikke å få fast ip :S
Planlegger å kjøre fiber direkte inn i FW (pFsense) har i dag fiber direkte inn i FMG som går via en hvit (patche?) boks? Er ikke mediekonverter til RJ45. Kan noen her bistå meg med å finne ut hvilken connector som er i enden som går inn i FMG? Er det LC single mode?
Jeg bruker en LC/UPC-SC/UPC fra patcheboks til fiberconverter
Sitat av Grossie Vis innlegg
Er det noen som har fått satt fast ip på enheter på nettverket sitt via altibox hjemmesentral? Det er den hvite skiten, Modell FMG3542

Trenger dette da jeg har et trådløst kamera som må ha portvidrekobling....... Men kameraet i seg selv støtter ikke å få fast ip :S
Vis hele sitatet...
Du får ikke satt noen fast IP på enheter som holder lenger enn neste omstart av hjemmesentralen.

Løsningene for å få til dette er å enten sette fast IP fra enheten du bruker (som du sier det ikke støtter), eller sette hjemmesentralen i bridge og koble opp eget utstyr.
Fast IP-adresse

For noen år siden fikk jeg opplyst fra min leverandør at IP-adressen skulle være stabil (fast) til tross for bruk av DHCP.

Etter å ha fått noen ubehagelige overraskelser hvor jeg fikk tildelt ny IP-adresse bestemte jeg meg for å bestille fast IP. Det skal sies at de gangene det skjedde var det i forbindelse med arbeid i sentral eller i nettet. De fleste gangene skjedde dette også uten forvarsel. For fast IP betaler jeg 10 kr per måned som egentlig ikke er noen upris.

Etter det har jeg levd relativt lykkelig med min fase IP-adresse. Helt til nå. 15. mai fikke jeg nemlig en SMS-melding fra min leverandør om at det vil bli utført arbeid i fibernettet, og at det ville medføre at jeg får tildelt en ny fast IP-adresse. Arbeide skulle utføres fra mandag 20. kl 00:00 og vare i inntil 6 timer. Flott, tenkte jeg. Da har jeg rikelig tid til å gjøre forberedelser med endringer i DNS og brannmur. Nå trenger jeg bare å kontakte leverandøren for å få oppgitt min nye IP-adresse.

Det skulle vise seg å være ikke helt enkelt. Operatøren på 1.-linje kunne som forventet ikke svare på det, men den hyggelige damen lovte å kontakte en tekniker på 2.-linje for å få svar. Hun ringte meg kort etter for å fortelle meg at dessverre, det er ikke mulig å vite IP-adressen på forhånd. Da stoppe det litt hos meg, hvordan er det mulig? Jeg har en spesifikk MAC-adresse på min ruter hjemme. Hvilken fibersnor som er min på sentralen og hvilken port på fiber-switchen den går inn på er kjent. Jeg går ut fra at jeg ikke er alene om å betale for fast IP-adresse. Hvordan er det da mulig å neglisjere en hel gruppe brukere som faktisk betaler for dette?

I ren frustrasjon skrev jeg et innlegg på Facebook-siden til Altibox om hva jeg synes om saken. Her er en direktelink til innlegget:
https://www.facebook.com/Altibox/pos...57242511499308

Jeg har fått vite at denne omleggingen er en del av en større reorganisering av nettet som gjøres av Altibox. Jeg er interessert i hvilke erfaringer andre i samme båt har. Være fri til å kommentere.
Sett opp dns korrekt. Det er totalt uproblematisk at ip ender seg.
Sitat av vidarlo Vis innlegg
Sett opp dns korrekt. Det er totalt uproblematisk at ip ender seg.
Vis hele sitatet...
DNS er korrekt satt opp, men er på innsiden av nettverket. Dermed må ny IP-adresse for navnetjeneren registreres hos NORID (via registrar).
Sitat av Tuxador Vis innlegg
DNS er korrekt satt opp, men er på innsiden av nettverket. Dermed må ny IP-adresse for navnetjeneren registreres hos NORID (via registrar).
Vis hele sitatet...
Ikkje host DNS heime. T.d. Cloudflare lar deg oppdatere via API, eller du kan hoste bind på en DO droplet til ein kopp kaffi i måneden.
Sitat av vidarlo Vis innlegg
Ikkje host DNS heime. T.d. Cloudflare lar deg oppdatere via API, eller du kan hoste bind på en DO droplet til ein kopp kaffi i måneden.
Vis hele sitatet...
Takk for omtanken. Jeg har allerede en dedikert server hos hetzner.com med virtuelle servere. Jeg bruker bind med et "split horizon"-oppsett for å ha navn på interne adresser. Da blir det fort upraktisk å ha navnetjeneren eksternt.

Jeg kan forøvrig anbefale https://hetzner.com. Ca 275 NOK pr måned er ikke så ille for en i7 med 32 GiB RAM, 4TB HD og flere faste IP adresser. CentOS med KVM virtualisering fungerer knall. For de som måtte være interessert "selger" Hetzner tilgang til renoverte dedikerte servere for en rimelig penge.
Sitat av vidarlo Vis innlegg
Ikkje host DNS heime.
Vis hele sitatet...
Ser ikke helt problemet. Har hostet master for diverse domener hjemme i 22 år nå. Nokså problemfritt.

I løpet av den samme perioden har jeg sett ørten sekundærtjenester komme og gå. Alle har vært gode og helt greit priset, men eksterne tjenester er uansett adskilling mindre stabilt enn det du selv lager.
Sitat av vidarlo Vis innlegg
T.d. Cloudflare lar deg oppdatere via API, eller du kan hoste bind på en DO droplet til ein kopp kaffi i måneden.
Vis hele sitatet...
Tviler ikke. Men det er funksjonalitet du ikke får med en slik tjeneste. F.eks. "split horizon" som @Tuxador har nevnt (og som for øvrig er en veldig dårlig idé, IMHO). Men også alle andre ting som krever konfigurasjon utenom sonefiler. De fleste slike APIer begrenser også hva du kan gjøre i sonefiler, og er dermed uegnet hvis du ønsker å teste ut mer obskure ting. Støtter de f.eks TLSA eller SSHFP? Jeg bruker begge deler for tiden.

Sitat av ofz3nz3 Vis innlegg
Planlegger å kjøre fiber direkte inn i FW (pFsense) har i dag fiber direkte inn i FMG som går via en hvit (patche?) boks? Er ikke mediekonverter til RJ45. Kan noen her bistå meg med å finne ut hvilken connector som er i enden som går inn i FMG? Er det LC single mode?
Vis hele sitatet...
Det er definitivt single mode. Har ikke FMG selv, og det kan vel i teorien tenkes at det uansett finnes mer enn én variant, så når det gjelder SC vs LC er det sikreste og enkleste å sjekke selv. Det er veldig lett å se forskjell. Sammenlign f.eks. med bildene på https://community.fs.com/blog/four-t...tch-cable.html

Merk også det som står om APC vs UPC. Dette er egentlig mest kritisk å få korrekt ettersom det har størst sannsynlighet for å brekke ting før du merker feilen. Du ser det lettest på fargen: Blå er UPC (forutsatt single mode), Grønn er APC.

De Altibox-installasjonene jeg har sett har brukt UPC. Mens jeg tror Telenor bruker APC på sitt GPON-utstyr. Nok en gang er det greiest å sjekke selv. Du kan stole på fargekodingen.
Sist endret av bmork; 21. mai 2019 kl. 12:44. Grunn: Automatisk sammenslåing med etterfølgende innlegg.
Sitat av bmork Vis innlegg
Ser ikke helt problemet. Har hostet master for diverse domener hjemme i 22 år nå. Nokså problemfritt.

I løpet av den samme perioden har jeg sett ørten sekundærtjenester komme og gå. Alle har vært gode og helt greit priset, men eksterne tjenester er uansett adskilling mindre stabilt enn det du selv lager.

Tviler ikke. Men det er funksjonalitet du ikke får med en slik tjeneste. F.eks. "split horizon" som @Tuxador har nevnt (og som for øvrig er en veldig dårlig idé, IMHO). Men også alle andre ting som krever konfigurasjon utenom sonefiler. De fleste slike APIer begrenser også hva du kan gjøre i sonefiler, og er dermed uegnet hvis du ønsker å teste ut mer obskure ting. Støtter de f.eks TLSA eller SSHFP? Jeg bruker begge deler for tiden.



Det er definitivt single mode. Har ikke FMG selv, og det kan vel i teorien tenkes at det uansett finnes mer enn én variant, så når det gjelder SC vs LC er det sikreste og enkleste å sjekke selv. Det er veldig lett å se forskjell. Sammenlign f.eks. med bildene på https://community.fs.com/blog/four-t...tch-cable.html

Merk også det som står om APC vs UPC. Dette er egentlig mest kritisk å få korrekt ettersom det har størst sannsynlighet for å brekke ting før du merker feilen. Du ser det lettest på fargen: Blå er UPC (forutsatt single mode), Grønn er APC.

De Altibox-installasjonene jeg har sett har brukt UPC. Mens jeg tror Telenor bruker APC på sitt GPON-utstyr. Nok en gang er det greiest å sjekke selv. Du kan stole på fargekodingen.
Vis hele sitatet...

Aldri sett noen altibox partnere som bruker APC mot sluttkunder.
▼ ... over en uke senere ... ▼
Hei, også jeg får bare NRK og lokale kanaler. Har prövd de triks jeg sett i tråden. Her er konfigen min, er det noen som ser hva jeg har glemt? Har slått av brannmur på utside interface vlan 101, og gjord en veldig snill masq-nat på iptv-lanet for å ikke bli slått av det.

eth0 = wan internet/iptv port
eth1 = lan iptv port

Kode

show interfaces ethernet eth0 description WAN
 duplex auto
 mac ec:xx:xx:xx:xx # spoofa mac fra gammel box
 speed auto
 vif 101 {
     address dhcp
     description IPTV-vlan-101-WAN
     dhcp-options {
         default-route no-update
         default-route-distance 255
         name-server update
     }
 }
 vif 102 {
     address dhcp
     description INTERNET-vlan-102-WAN
     firewall {
         in {
             name IN-WAN
         }
     }
 }
igmp-proxy config. eth0.101 til altibox. eth1.101 iptvLAN

Kode

show protocols igmp-proxy 
 interface eth0.101 {
     alt-subnet 0.0.0.0/0
     role upstream
     threshold 1
 }
 interface eth1.101 {
     alt-subnet 0.0.0.0/0
     role downstream
     threshold 1
 }


Her får jeg IP på både Internet og IPTV interface.

Kode

show interfaces        
---------    ----------                        ---  -----------                 
eth0         -                                 u/u  WAN                         
eth0.101     10.x.x.x/23                 u/u  IPTV-vlan101-WAN            
eth0.102     51.x.x.x/17                 u/u  INTERNET-vlan-102-WAN
       ...
eth1.101     192.168.101.1/24                  u/u  IPTV-vlan101-LAN


Dekoderen får IP fra riktig nett, og får riktig DNS-server som jeg fått av altibox på eth0.102 (wan-internet). Har også prövd å sette lokal DNS forwarding på eth1.101 og upstream forwarding til 109.247.114.4 og 92.220.228.70

Kode

show service dhcp-server shared-network-name IPTV-LAN 
 authoritative enable
 subnet 192.168.101.0/24 {
     default-router 192.168.101.1
     dns-server 109.247.114.4
     dns-server 92.220.228.70
     lease 86400
     start 192.168.101.101 {
         stop 192.168.101.199
     }
 }


statisk route til 172.21.0.0/16 via altibox eth0.101 gw.

Kode

show ip route
IP Route Table for VRF "default"
S    *> 0.0.0.0/0 [210/0] via 51.x.x.1, eth0.102 # internet default
C    *> 10.x.x.0/23 is directly connected, eth0.101 # wan iptv
C    *> 51.x.x.0/17 is directly connected, eth0.102 # wan internet
S    *> 172.21.0.0/16 [1/0] via 10.x.x.1, eth0.101 # static 
C    *> 172.16.216.0/24 is directly connected, eth1 #kontorlan
C    *> 172.16.217.0/24 is directly connected, eth2 # kontorlan 
C    *> 172.16.226.0/24 is directly connected, eth2.226 # kontorlan
C    *> 192.168.101.0/24 is directly connected, eth1.101 # iptv lan

sourcenat masquerade på ting som som skal ut av WAN iptv vlan 101.

Kode

show service nat rule 5000
 description "MASQ for ALTIBOX IPTV"
 destination {
     address 172.21.0.0/16
 }
 log disable
 outbound-interface eth0.101
 protocol all
 type masquerade

Det kommer noe data. Men det er bara NRK...

Kode

show ip multicast mfc 
Group           Origin           In          Out                Pkts         Bytes  Wrong
239.254.127.63  172.16.216.203   eth0.101    eth1                  3       348.00b      3
239.255.255.250 172.16.217.22    eth0.101    eth1                876      144.54KB    876
239.255.255.250 172.16.217.22    eth0.101    eth2                876      144.54KB    876
224.2.2.2       81.166.112.36    eth0.101    eth1.101             19        4.31KB      0
224.2.2.207     81.166.113.232   eth0.101    eth1.101            370       26.38KB      0
224.2.2.207     81.166.113.230   eth0.101    eth1.101            370       26.02KB      0
224.2.2.207     81.166.113.233   eth0.101    eth1.101            367       26.16KB      0
224.2.2.207     81.166.113.229   eth0.101    eth1.101            372       26.16KB      0
224.2.2.207     81.166.113.236   eth0.101    eth1.101            471       29.44KB      0
224.2.2.207     81.166.113.228   eth0.101    eth1.101            366       25.73KB      0
224.2.2.207     81.166.113.231   eth0.101    eth1.101            668      146.19KB      0
239.192.1.179   84.234.204.244   eth0.101    eth1.101              2        2.62KB      0
239.192.1.190   84.234.204.243   eth0.101    eth1.101             10       13.12KB      0
239.192.1.179   10.xx.xx.xx   --                                                      


show ip multicast interfaces 
Intf             BytesIn        PktsIn      BytesOut       PktsOut            Local
eth1               0.00b             0         0.00b             0     172.16.216.1
eth2               0.00b             0         0.00b             0     172.16.217.1
eth1.101           0.00b             0       76.69MB         61673    192.168.101.1
eth0.102           0.00b             0         0.00b             0   51.x.xx.xx
eth0.101         76.12MB         61214         0.00b             0   10.x.x.x
Sitat av qwerty1234 Vis innlegg
Hei, også jeg får bare NRK og lokale kanaler. Har prövd de triks jeg sett i tråden. Her er konfigen min, er det noen som ser hva jeg har glemt? Har slått av brannmur på utside interface vlan 101, og gjord en veldig snill masq-nat på iptv-lanet for å ikke bli slått av det.

eth0 = wan internet/iptv port
eth1 = lan iptv port

Kode

show interfaces ethernet eth0 description WAN
 duplex auto
 mac ec:xx:xx:xx:xx # spoofa mac fra gammel box
 speed auto
 vif 101 {
     address dhcp
     description IPTV-vlan-101-WAN
     dhcp-options {
         default-route no-update
         default-route-distance 255
         name-server update
     }
 }
 vif 102 {
     address dhcp
     description INTERNET-vlan-102-WAN
     firewall {
         in {
             name IN-WAN
         }
     }
 }
igmp-proxy config. eth0.101 til altibox. eth1.101 iptvLAN

Kode

show protocols igmp-proxy 
 interface eth0.101 {
     alt-subnet 0.0.0.0/0
     role upstream
     threshold 1
 }
 interface eth1.101 {
     alt-subnet 0.0.0.0/0
     role downstream
     threshold 1
 }


Her får jeg IP på både Internet og IPTV interface.

Kode

show interfaces        
---------    ----------                        ---  -----------                 
eth0         -                                 u/u  WAN                         
eth0.101     10.x.x.x/23                 u/u  IPTV-vlan101-WAN            
eth0.102     51.x.x.x/17                 u/u  INTERNET-vlan-102-WAN
       ...
eth1.101     192.168.101.1/24                  u/u  IPTV-vlan101-LAN


Dekoderen får IP fra riktig nett, og får riktig DNS-server som jeg fått av altibox på eth0.102 (wan-internet). Har også prövd å sette lokal DNS forwarding på eth1.101 og upstream forwarding til 109.247.114.4 og 92.220.228.70

Kode

show service dhcp-server shared-network-name IPTV-LAN 
 authoritative enable
 subnet 192.168.101.0/24 {
     default-router 192.168.101.1
     dns-server 109.247.114.4
     dns-server 92.220.228.70
     lease 86400
     start 192.168.101.101 {
         stop 192.168.101.199
     }
 }


statisk route til 172.21.0.0/16 via altibox eth0.101 gw.

Kode

show ip route
IP Route Table for VRF "default"
S    *> 0.0.0.0/0 [210/0] via 51.x.x.1, eth0.102 # internet default
C    *> 10.x.x.0/23 is directly connected, eth0.101 # wan iptv
C    *> 51.x.x.0/17 is directly connected, eth0.102 # wan internet
S    *> 172.21.0.0/16 [1/0] via 10.x.x.1, eth0.101 # static 
C    *> 172.16.216.0/24 is directly connected, eth1 #kontorlan
C    *> 172.16.217.0/24 is directly connected, eth2 # kontorlan 
C    *> 172.16.226.0/24 is directly connected, eth2.226 # kontorlan
C    *> 192.168.101.0/24 is directly connected, eth1.101 # iptv lan

sourcenat masquerade på ting som som skal ut av WAN iptv vlan 101.

Kode

show service nat rule 5000
 description "MASQ for ALTIBOX IPTV"
 destination {
     address 172.21.0.0/16
 }
 log disable
 outbound-interface eth0.101
 protocol all
 type masquerade

Det kommer noe data. Men det er bara NRK...

Kode

show ip multicast mfc 
Group           Origin           In          Out                Pkts         Bytes  Wrong
239.254.127.63  172.16.216.203   eth0.101    eth1                  3       348.00b      3
239.255.255.250 172.16.217.22    eth0.101    eth1                876      144.54KB    876
239.255.255.250 172.16.217.22    eth0.101    eth2                876      144.54KB    876
224.2.2.2       81.166.112.36    eth0.101    eth1.101             19        4.31KB      0
224.2.2.207     81.166.113.232   eth0.101    eth1.101            370       26.38KB      0
224.2.2.207     81.166.113.230   eth0.101    eth1.101            370       26.02KB      0
224.2.2.207     81.166.113.233   eth0.101    eth1.101            367       26.16KB      0
224.2.2.207     81.166.113.229   eth0.101    eth1.101            372       26.16KB      0
224.2.2.207     81.166.113.236   eth0.101    eth1.101            471       29.44KB      0
224.2.2.207     81.166.113.228   eth0.101    eth1.101            366       25.73KB      0
224.2.2.207     81.166.113.231   eth0.101    eth1.101            668      146.19KB      0
239.192.1.179   84.234.204.244   eth0.101    eth1.101              2        2.62KB      0
239.192.1.190   84.234.204.243   eth0.101    eth1.101             10       13.12KB      0
239.192.1.179   10.xx.xx.xx   --                                                      


show ip multicast interfaces 
Intf             BytesIn        PktsIn      BytesOut       PktsOut            Local
eth1               0.00b             0         0.00b             0     172.16.216.1
eth2               0.00b             0         0.00b             0     172.16.217.1
eth1.101           0.00b             0       76.69MB         61673    192.168.101.1
eth0.102           0.00b             0         0.00b             0   51.x.xx.xx
eth0.101         76.12MB         61214         0.00b             0   10.x.x.x
Vis hele sitatet...
Ser ut som du har feil interface på downstream på igmp-proxy.
Mangler også static route ser det ut som.
Ligger jo allerede ferdige konfig ute i tråden.
https://freak.no/forum/showthread.ph...05#post3429405
Sitat av guleman Vis innlegg
Ser ut som du har feil interface på downstream på igmp-proxy.
Mangler også static route ser det ut som.
Ligger jo allerede ferdige konfig ute i tråden.
https://freak.no/forum/showthread.ph...05#post3429405
Vis hele sitatet...
Hei takk for svar. Det er mye info som er feil i denne tråd. I hvert fall for mitt oppsett.
Jeg bruker eth0.101 upstream og eth1.101 er downstream, så det er riktig.

Jeg har en motorola dekoder fra 2015 elns.

F.eks så er ikke routen til 172.21.0.0./16 nödvendig.
Heller trenger du ikke ha DNS til altibox.


Så, det viktige stegen som skulle til for meg var:
1) spoofe mac-address til gammel altibox router. Dette for å få DHCP-IP på wanport vlan 101. ellers fikk jeg bare ip på vlan 102.

2) Hvis du önsker, lag et eget IPTV lan. Det har ikke noe å si hvilken DNS den bruker.
Sett igmp-proxy upstream på wanport-vlan101. igmpproxy downstream på tv-dekoder lan interface.

3) ta nå "show interfaces ethernet <ditt_IPTV_Local_network> capture port 1600.
Restart tv dekoder (ström ut og inn)
Ser att dekoder pröver å snakke med 109.247.117.12 på port 1600.
Lag en static route till den IPn over gateway som du fikk på wan-vlan101 interfacet.
Lag en masquerade nat til den IPn over gateway som du fikk på wan-vlan101 interfacet.
Hei
Prøver å sette opp internett og IPTV på en OpenWRT ruter, men sliter litt med IPTV delen. Internett virker, men på IPTV får jeg først bare svart skjerm med en feilmelding og så etterhvert kommer NRK opp, men ikke noe annet. Hva tyder dette på? Noen forslag på hva det er som mangler i min konfigurasjon?
Sist endret av Morove; 3 uker siden kl. 22:53.
Sitat av Morove Vis innlegg
Hei
Prøver å sette opp internett og IPTV på en OpenWRT ruter, men sliter litt med IPTV delen. Internett virker, men på IPTV får jeg først bare svart skjerm med en feilmelding og så etterhvert kommer NRK opp, men ikke noe annet. Hva tyder dette på? Noen forslag på hva det er som mangler i min konfigurasjon?
Vis hele sitatet...
Prøv med det jeg skrev i siste post... Lenge siden jeg brukte OpenWRT, men det må vel være et tcpdump kommando på den saken der?
Sitat av qwerty1234 Vis innlegg
Hei takk for svar. Det er mye info som er feil i denne tråd. I hvert fall for mitt oppsett.
Jeg bruker eth0.101 upstream og eth1.101 er downstream, så det er riktig.

Jeg har en motorola dekoder fra 2015 elns.

F.eks så er ikke routen til 172.21.0.0./16 nödvendig.
Heller trenger du ikke ha DNS til altibox.


Så, det viktige stegen som skulle til for meg var:
1) spoofe mac-address til gammel altibox router. Dette for å få DHCP-IP på wanport vlan 101. ellers fikk jeg bare ip på vlan 102.

2) Hvis du önsker, lag et eget IPTV lan. Det har ikke noe å si hvilken DNS den bruker.
Sett igmp-proxy upstream på wanport-vlan101. igmpproxy downstream på tv-dekoder lan interface.

3) ta nå "show interfaces ethernet <ditt_IPTV_Local_network> capture port 1600.
Restart tv dekoder (ström ut og inn)
Ser att dekoder pröver å snakke med 109.247.117.12 på port 1600.
Lag en static route till den IPn over gateway som du fikk på wan-vlan101 interfacet.
Lag en masquerade nat til den IPn over gateway som du fikk på wan-vlan101 interfacet.
Vis hele sitatet...
Da har du den gamle tv løsningen. Er bare å skille ut vlan 101 og 102 uten noe mer konfigurasjon. Trenger ikke noe igmp proxy der for å få det til å fungere.

Sitat av Morove Vis innlegg
Hei
Prøver å sette opp internett og IPTV på en OpenWRT ruter, men sliter litt med IPTV delen. Internett virker, men på IPTV får jeg først bare svart skjerm med en feilmelding og så etterhvert kommer NRK opp, men ikke noe annet. Hva tyder dette på? Noen forslag på hva det er som mangler i min konfigurasjon?
Vis hele sitatet...
Har ingen forslag og kan ikke noe om OpenWRT, men skal du ha hjelp må du nesten dele din konfig
▼ ... over en uke senere ... ▼
Hei, folkens!

Eg prøvar å få kopla min Altibox FMG (i bridge) via ein UniFi USG Pro på ein slik måte at eg kan få både Internett og IPTV ut på eitt LAN på baksida av USG-en.

Ethernet-portane på USG-en er kopla som fylgjer:

LAN1 (eth0): LAN
LAN2 (eth1): Inaktiv
WAN1 (eth2): Internett (eth4 frå FMG)
WAN2 (eth3): IPTV (eth1 frå FMG)

Eg har akivera IGMP Snooping i switch (USG PoE-switch).

Vidare så har eg prøvd å setje opp IGMP Proxy og anna naudsynt konfigurasjon for USG via fylgjande config.gateway.json-fil:

Kode

{	
	"interfaces": {
		"ethernet": {
			"eth0": {
				"address": "10.160.10.1/24",
				"description": "LAN",
				"duplex": "auto",
				"speed": "auto"
			},
			"eth2": {
				"address": "dhcp",
				"description": "Internet",
				"duplex": "auto",
				"firewall": {
					"in": {
						"name": "WAN_IN"
					},
					"local": {
						"name": "WAN_LOCAL"
					}
				},
				"mac": "XX:XX:XX:XX:XX:XX",
				"speed": "auto"
			},
			"eth3": {
				"address": "dhcp",
				"description": "IPTV",
				"dhcp-options": {
					"default-route": "no-update",
					"default-route-distance": "210",
					"name-server": "update"
				},
				"duplex": "auto",
				"speed": "auto"
			}
		},
		"loopback": {
			"lo": "''"
		}
	},
	"protocols": {
		"igmp-proxy": {
			"interface": {
				"eth0": {
					"alt-subnet": "172.21.0.0/16",
					"role": "downstream",
					"threshold": "1"
				},
				"eth3": {
					"alt-subnet": "172.21.0.0/16",
					"role": "upstream",
					"threshold": "1"
				}
			}
		},
		"static": {
			"route": {
				"0.0.0.0/0": {
					"next-hop": "YYY.YYY.YYY.YYY"
				},
				"172.21.0.0/16": {
					"next-hop": "192.168.10.1"
				}
			}	
		}
	},
	"service": {
		"nat": {
			"rule": {
				"5010": {
					"description": "masquerade for WAN",
					"destination": {
						"address": "0.0.0.0/0"
					},
					"outbound-interface": "eth2",
					"protocol": "all",
					"type": "masquerade"
				},
				"5015": {
					"description": "masquerade for IPTV",
					"destination": {
						"address": "172.21.0.0/16"
					},
					"outbound-interface": "eth3",
					"type": "masquerade"
				}
			}
		}
	}
}
XX:XX:XX:XX:XX:XX er MAC-adressa til FMG-en. YYY.YYY.YYY.YYY er standard gateway for FMG-en.

Ut frå alt eg har klara å finne ut etter mange timar med leiting på nettet så skulle dette ha fungert, men det gjer det ikkje...

Det som skjer er at når eg legg inn denne config.gateway.json-fila så går USG-en i ein såkalla "provisioning loop", og ingenting fungerer før eg slettar json-fila att.

Nokon idear om kva eg gjer feil?

Dette er kanskje eit dumt spørsmål, men må eg opne WAN2-porten på USG via UI eller ikkje? Viss ja så er eg noko uviss på kva innstillingar eg skal bruke her:



Som de ser så kan eg for "Load Balancing" velje "Failover only" eller "Weighted LB". Men dette vert vel noko feil, då det ikkje er load balancing WAN2 skal brukast til i det heile teke? Skal eg berre la vere å gjere noko her?

Eg vonar nokon har eitt og anna innspel her, eg skulle veldig gjerne fått dette til å fungere no...
Sist endret av Garegaupa; 2 uker siden kl. 13:16. Grunn: Automatisk sammenslåing med etterfølgende innlegg.
Spør her om den fysiske installasjonen av Altibox fra nye.

Hjemmesentralen skal stå i ett eget skap. Det vil gå i trekkrør fra husvegg og inn. Hvor stort trekkrør bør legges opp?
Sist endret av MeTheWall; 2 uker siden kl. 16:12. Grunn: Fjernet tekst som kom med flere ganger.
Jeg ønsker fjerne P2812ac som jeg har og antingen bruke en pfsense (dedikert server med dual intel nic) eller bruke en edgerouter poe som jeg har liggendes. Jeg ønsker at den skal håndtere tv og internett på samme utgang til resten av huset. Øsnker om mulig og ha openvpn kjørendes på den.

Er det noen som kan hjelpe med en oppskrift til hvordan sette dette opp? Har ikke sett noen konfig her til edgerouter poe eller en guide til oppsett av pfsense.

Kan gjerne sende ett 'bidrag' til noen som kan hjelpe meg med et slikt oppsett.
Sitat av irvmic Vis innlegg
Jeg ønsker fjerne P2812ac som jeg har og antingen bruke en pfsense (dedikert server med dual intel nic) eller bruke en edgerouter poe som jeg har liggendes. Jeg ønsker at den skal håndtere tv og internett på samme utgang til resten av huset. Øsnker om mulig og ha openvpn kjørendes på den.

Er det noen som kan hjelpe med en oppskrift til hvordan sette dette opp? Har ikke sett noen konfig her til edgerouter poe eller en guide til oppsett av pfsense.

Kan gjerne sende ett 'bidrag' til noen som kan hjelpe meg med et slikt oppsett.
Vis hele sitatet...
Se her for oppsett på edgerouter
https://freak.no/forum/showthread.ph...05#post3429405
Sist endret av guleman; 2 uker siden kl. 18:13.
Alt du trenger for pfsense står i denne tråden. Er bare det å finne det ��
Sist endret av MeTheWall; 2 uker siden kl. 21:24. Grunn: Fjernet tekst som kom med dobbelt.
Sitat av janolov Vis innlegg
Alt du trenger for pfsense står i denne tråden. Er bare det å finne det ��

Alt du trenger for pfsense står i denne tråden. Er bare det å finne det 😉
Vis hele sitatet...
Ja og det er helt enkelt
Hei.

Har prøvd å følge guiden for en Mikrotik, men får ikke internett til å fungere engang. Noen som ser noen åpenbare feil i min konfig?

Fulgte guiden slavisk, bortsett fra at guiden brukte Bridge1 og jeg brukte Bridge.

Kode

# jun/11/2019 11:47:15 by RouterOS 6.44.3
# software id = 95UJ-BLUU
#
# model = 960PGS
# serial number = XXXXXXXXX
/interface bridge
add admin-mac=5C:6A:XX:XX:XX:XX auto-mac=no fast-forward=no name=IPTV-Bridge
add admin-mac=74:4D:28:48:BD:7F auto-mac=no comment=defconf igmp-snooping=yes \
    name=bridge
/interface ethernet
set [ find default-name=ether1 ] mac-address=5C:6A:XX:XX:XX:XX
/interface vlan
add comment=Phone interface=ether1 name=vlan100 vlan-id=100
add comment=IPTV interface=ether1 name=vlan101 vlan-id=101
add comment=Internet interface=ether1 name=vlan102 vlan-id=102
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=default-dhcp ranges=192.168.88.10-192.168.88.254
/ip dhcp-server
add address-pool=default-dhcp disabled=no interface=bridge name=defconf
/interface bridge port
add bridge=bridge comment=defconf interface=ether2
add bridge=bridge comment=defconf interface=ether3
add bridge=bridge comment=defconf interface=ether4
add bridge=bridge comment=defconf interface=ether5
add bridge=bridge comment=defconf interface=sfp1
add bridge=IPTV-Bridge interface=vlan101
/ip neighbor discovery-settings
set discover-interface-list=LAN
/interface list member
add comment=defconf interface=bridge list=LAN
add comment=defconf interface=ether1 list=WAN
/ip address
add address=192.168.88.1/24 comment=defconf interface=bridge network=\
    192.168.88.0
/ip dhcp-client
add comment=Internett dhcp-options=hostname,clientid disabled=no interface=\
    vlan102
add add-default-route=no comment=IPTV dhcp-options=clientid,hostname \
    disabled=no interface=IPTV-Bridge
/ip dhcp-server network
add address=192.168.88.0/24 comment=defconf gateway=192.168.88.1
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.88.1 name=router.lan
/ip firewall filter
add action=accept chain=input protocol=udp
add action=accept chain=input protocol=igmp
add action=accept chain=forward protocol=udp
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment=\
    "defconf: accept established,related,untracked" connection-state=\
    established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=\
    invalid
add action=drop chain=input comment="defconf: drop all not coming from LAN" \
    in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" \
    ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" \
    ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
    connection-state=established,related disabled=yes
add action=accept chain=forward comment=\
    "defconf: accept established,related, untracked" connection-state=\
    established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" \
    connection-state=invalid
add action=drop chain=forward comment=\
    "defconf:  drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
    connection-state=new in-interface-list=WAN
add action=drop chain=input dst-port=53 in-interface=vlan102 protocol=udp
/ip firewall mangle
add action=mark-routing chain=prerouting dst-address=172.21.0.0/16 \
    new-routing-mark=IPTV-Mark passthrough=yes src-address=0.0.0.0/0
/ip firewall nat
add action=masquerade chain=srcnat out-interface=vlan102 to-addresses=0.0.0.0
add action=masquerade chain=srcnat out-interface=IPTV-Bridge
/ip route
add distance=1 gateway=10.174.22.1 routing-mark=IPTV-Mark
/ip route rule
add routing-mark=IPTV-Mark table=IPTV-Mark
/routing igmp-proxy
set quick-leave=yes
/routing igmp-proxy interface
add alternative-subnets=0.0.0.0/0 interface=IPTV-Bridge upstream=yes
add interface=bridge
/system clock
set time-zone-name=Europe/Oslo
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN
EDIT: En reboot av routeren var vist det som skulle til. Nå fungerer TV og internett. Super guide, da var det bare resten igjen.
Sist endret av stianiquniez; 2 uker siden kl. 20:24. Grunn: Automatisk sammenslåing med etterfølgende innlegg.
prøvd følge guides her med konfig av min edgerouter poe.
Får ikke noe dhcp på vlan 102. 101 gir dhcp med en gang.

Kode

 show dhcp client leases
interface  : eth1.101
ip address : 10.170.134.36      [Active]
subnet mask: 255.255.254.0
domain name: lyse.net   [overridden by domain-name set using CLI]
router     : 10.170.134.1
name server: 92.220.228.70 109.247.114.4
dhcp server: 109.247.116.53
lease time : 85490
last update: Fri Jan 2 13:25:32 UTC 2015
expiry     : Sat Jan 03 13:10:13 UTC 2015
reason     : REBOOT

interface  : eth1.102
last update: Fri Jan 2 13:26:27 UTC 2015
reason     : FAIL

interface  : eth1
last update: Fri Jan 2 13:26:27 UTC 2015
reason     : FAIL
Skal jeg sette på bridge mode på mine sider på vikenfiber eller ikke?
Mac adressen jeg har brukt er den som står på undersiden av min zyxel 2812. Har bare delt de opp parvis med : imellom.

Dette er min konfig jeg har nå

Kode

firewall {
    all-ping enable
    broadcast-ping disable
    ipv6-receive-redirects disable
    ipv6-src-route disable
    ip-src-route disable
    log-martians enable
    name WAN_IN {
        default-action drop
        description "WAN to internal"
        rule 10 {
            action accept
            description "Allow established/related"
            state {
                established enable
                related enable
            }
        }
        rule 20 {
            action drop
            description "Drop invalid state"
            state {
                invalid enable
            }
        }
    }
    name WAN_LOCAL {
        default-action drop
        description "WAN to router"
        rule 10 {
            action accept
            description "Allow established/related"
            state {
                established enable
                related enable
            }
        }
        rule 20 {
            action drop
            description "Drop invalid state"
            state {
                invalid enable
            }
        }
    }
    receive-redirects disable
    send-redirects enable
    source-validation disable
    syn-cookies enable
}
interfaces {
    ethernet eth0 {
        address 192.168.1.1/24
        duplex auto
        poe {
            output off
        }
        speed auto
    }
    ethernet eth1 {
        address dhcp
        duplex auto
		mac xx:xx:xx:xx:xx:xx
        poe {
            output off
        }
        speed auto
        vif 100 {
            description ALTIBOX_CONFIG
            mtu 1500
        }
        vif 101 {
            address dhcp
            description TV_WAN
            dhcp-options {
                default-route no-update
                default-route-distance 210
                name-server update
            }
        }
        vif 102 {
            address dhcp
            description Internetwan
            firewall {
                in {
                    name WAN_IN
                }
                local {
                    name WAN_LOCAL
                }
            }
        }
    }
    ethernet eth2 {
        duplex auto
        poe {
            output off
        }
        speed auto
    }
    ethernet eth3 {
        duplex auto
        poe {
            output off
        }
        speed auto
    }
    ethernet eth4 {
        address 192.168.200.1/24
        description "LAN Network"
        duplex auto
        mtu 1500
        poe {
            output off
        }
        speed auto
    }
    loopback lo {
    }
    switch switch0 {
        mtu 1500
    }
}
protocols {
    igmp-proxy {
        interface eth1.101 {
            alt-subnet 0.0.0.0/0
            role upstream
            threshold 1
        }
        interface eth4 {
            alt-subnet 0.0.0.0/0
            role downstream
            threshold 1
        }
    }
    static {
        route 172.21.0.0/16 {
            next-hop 10.170.134.1 {
            }
        }
    }
}
service {
    gui {
        http-port 80
        https-port 443
        older-ciphers enable
    }
    nat {
        rule 5010 {
            description "masquerade for WAN"
            outbound-interface eth1.102
            type masquerade
        }
        rule 5011 {
            description "masquerade for TV_WAN"
            destination {
                address 172.21.0.0/16
            }
            outbound-interface eth1.101
            protocol all
            type masquerade
        }
    }
    ssh {
        port 22
        protocol-version v2
    }
    unms {
        disable
    }
}
prøvd følge guides her med konfig av min edgerouter poe.
Får ikke noe dhcp på vlan 102. 101 gir dhcp med en gang.

Kode

 show dhcp client leases
interface  : eth1.101
ip address : 10.170.134.36      [Active]
subnet mask: 255.255.254.0
domain name: lyse.net   [overridden by domain-name set using CLI]
router     : 10.170.134.1
name server: 92.220.228.70 109.247.114.4
dhcp server: 109.247.116.53
lease time : 85490
last update: Fri Jan 2 13:25:32 UTC 2015
expiry     : Sat Jan 03 13:10:13 UTC 2015
reason     : REBOOT

interface  : eth1.102
last update: Fri Jan 2 13:26:27 UTC 2015
reason     : FAIL

interface  : eth1
last update: Fri Jan 2 13:26:27 UTC 2015
reason     : FAIL
Skal jeg sette på bridge mode på mine sider på vikenfiber eller ikke?
Mac adressen jeg har brukt er den som står på undersiden av min zyxel 2812. Har bare delt de opp parvis med : imellom.

Dette er min konfig jeg har nå

Kode

firewall {
    all-ping enable
    broadcast-ping disable
    ipv6-receive-redirects disable
    ipv6-src-route disable
    ip-src-route disable
    log-martians enable
    name WAN_IN {
        default-action drop
        description "WAN to internal"
        rule 10 {
            action accept
            description "Allow established/related"
            state {
                established enable
                related enable
            }
        }
        rule 20 {
            action drop
            description "Drop invalid state"
            state {
                invalid enable
            }
        }
    }
    name WAN_LOCAL {
        default-action drop
        description "WAN to router"
        rule 10 {
            action accept
            description "Allow established/related"
            state {
                established enable
                related enable
            }
        }
        rule 20 {
            action drop
            description "Drop invalid state"
            state {
                invalid enable
            }
        }
    }
    receive-redirects disable
    send-redirects enable
    source-validation disable
    syn-cookies enable
}
interfaces {
    ethernet eth0 {
        address 192.168.1.1/24
        duplex auto
        poe {
            output off
        }
        speed auto
    }
    ethernet eth1 {
        address dhcp
        duplex auto
		mac xx:xx:xx:xx:xx:xx
        poe {
            output off
        }
        speed auto
        vif 100 {
            description ALTIBOX_CONFIG
            mtu 1500
        }
        vif 101 {
            address dhcp
            description TV_WAN
            dhcp-options {
                default-route no-update
                default-route-distance 210
                name-server update
            }
        }
        vif 102 {
            address dhcp
            description Internetwan
            firewall {
                in {
                    name WAN_IN
                }
                local {
                    name WAN_LOCAL
                }
            }
        }
    }
    ethernet eth2 {
        duplex auto
        poe {
            output off
        }
        speed auto
    }
    ethernet eth3 {
        duplex auto
        poe {
            output off
        }
        speed auto
    }
    ethernet eth4 {
        address 192.168.200.1/24
        description "LAN Network"
        duplex auto
        mtu 1500
        poe {
            output off
        }
        speed auto
    }
    loopback lo {
    }
    switch switch0 {
        mtu 1500
    }
}
protocols {
    igmp-proxy {
        interface eth1.101 {
            alt-subnet 0.0.0.0/0
            role upstream
            threshold 1
        }
        interface eth4 {
            alt-subnet 0.0.0.0/0
            role downstream
            threshold 1
        }
    }
    static {
        route 172.21.0.0/16 {
            next-hop 10.170.134.1 {
            }
        }
    }
}
service {
    gui {
        http-port 80
        https-port 443
        older-ciphers enable
    }
    nat {
        rule 5010 {
            description "masquerade for WAN"
            outbound-interface eth1.102
            type masquerade
        }
        rule 5011 {
            description "masquerade for TV_WAN"
            destination {
                address 172.21.0.0/16
            }
            outbound-interface eth1.101
            protocol all
            type masquerade
        }
    }
    ssh {
        port 22
        protocol-version v2
    }
    unms {
        disable
    }
}
Sist endret av irvmic; 1 uke siden kl. 13:14. Grunn: Automatisk sammenslåing med etterfølgende innlegg.
Ser du ber om dhcp adresse på eth1 uten vlan, virker som denne delen skulle stått inni vlan 100.
for dhcp-option på vlan102 kan du nok også legge på default-route update.

forsøk også en release dhcp interface eth1.102 deretter en renew dhcp interface eth1.102. Stusser litt på at det det står at du har fått en dhcp lease på vlan 101 i 2015, er klokken korrekt på routeren din. (tror ikke egentlig det har noe å si for lease på vlan102, synes bare det var rart)
Ser du ber om dhcp adresse på eth1 uten vlan, virker som denne delen skulle stått inni vlan 100.
for dhcp-option på vlan102 kan du nok også legge på default-route update.

forsøk også en release dhcp interface eth1.102 deretter en renew dhcp interface eth1.102. Stusser litt på at det det står at du har fått en dhcp lease på vlan 101 i 2015, er klokken korrekt på routeren din. (tror ikke egentlig det har noe å si for lease på vlan102, synes bare det var rart)
Sitat av Trrunde Vis innlegg
Ser du ber om dhcp adresse på eth1 uten vlan, virker som denne delen skulle stått inni vlan 100.
for dhcp-option på vlan102 kan du nok også legge på default-route update.

forsøk også en release dhcp interface eth1.102 deretter en renew dhcp interface eth1.102. Stusser litt på at det det står at du har fått en dhcp lease på vlan 101 i 2015, er klokken korrekt på routeren din. (tror ikke egentlig det har noe å si for lease på vlan102, synes bare det var rart)
Vis hele sitatet...
Såg den feilen nå og fikk fjernet DHCP for ETH1.
Klokken blir feil frem til jeg får internet og kan hente NTP klokke grunnet at denne routern ikke har en RTC.

Får fortsatt samme feil dog med DHCP.

Kode

show dhcp client leases
interface  : eth1.101
ip address : 10.170.134.36      [Active]
subnet mask: 255.255.254.0
domain name: lyse.net   [overridden by domain-name set using CLI]
router     : 10.170.134.1
name server: 92.220.228.70 109.247.114.4
dhcp server: 109.247.116.53
lease time : 71001
last update: Fri Jan 2 14:34:06 UTC 2015
expiry     : Sat Jan 03 10:17:22 UTC 2015
reason     : BOUND

interface  : eth1.102
last update: Fri Jan 2 14:34:59 UTC 2015
reason     : FAIL
  • Er det min mac avlesing som er feil da? Har tatt min mac adress som står i bunn på min Zyxel router og bare lagt : imellom 123456789012 og gjort den til 12:34:56:78:90:12 ? Er det riktigt?
  • Skal jeg ha satt min router i bridge mode på altibox sine hjemme sider?
  • Må jeg ha en venteperiode fra jeg stenger ned min zyxel router frem til jeg starter opp min egen router for å få riktig dhcp? Om ja hvor lenge?

Takksom for all hjelp jeg kan få.
Sitat av irvmic Vis innlegg

Kode

interface  : eth1.102
last update: Fri Jan 2 14:34:59 UTC 2015
reason     : FAIL
Vis hele sitatet...
Nå kan jeg ingenting om edgerouter config, men for meg ser det ut som om du har en brannmur som blokkerer DHCP på dette interface.
Sitat av bmork Vis innlegg
Nå kan jeg ingenting om edgerouter config, men for meg ser det ut som om du har en brannmur som blokkerer DHCP på dette interface.
Vis hele sitatet...
Hva jeg kan se så er mine firewall regler presis like som de som får alt til å virke.

Mulig jeg leser feil. Er ikke veldigt kunnig i edgerouters selv.
forsøkt å sende en dhcp release og deretter en dhcp renew på vlan 102? Hvor lenge har du hatt edgerouter koblet til? Lenger enn dhcp leasetid for vlanet?
Sitat av irvmic Vis innlegg
Hva jeg kan se så er mine firewall regler presis like som de som får alt til å virke.
Vis hele sitatet...
Hvilken regel skal liksom slippe gjennom svaret fra DHCP-serveren?
Hei, jeg har en del lag pa tvn naar jeg ser pa de fleste kanaler. Bildet hakker til litt, men lyden er som regel bra.
Jeg har en edgerouter lite, men top paa den viser ikke 100% cpu. Kan det vaere annet som er flaskehalsen?

I dagene fikk jeg i tillegg den nye tv loesningen. Fikk en ny router, som har SFP port, sa da tenkte jeg det er pa tide aa fjerne den gamle media konvertern som er i skapet mitt. Noen som har noe aa si om edgerouter X SFP? Klarer den aa lese den SFP man fikk av altibox?
Sitat av qwerty1234 Vis innlegg
Hei, jeg har en del lag pa tvn naar jeg ser pa de fleste kanaler. Bildet hakker til litt, men lyden er som regel bra.
Jeg har en edgerouter lite, men top paa den viser ikke 100% cpu. Kan det vaere annet som er flaskehalsen?

I dagene fikk jeg i tillegg den nye tv loesningen. Fikk en ny router, som har SFP port, sa da tenkte jeg det er pa tide aa fjerne den gamle media konvertern som er i skapet mitt. Noen som har noe aa si om edgerouter X SFP? Klarer den aa lese den SFP man fikk av altibox?
Vis hele sitatet...
Edgeoruter klarer fint å kjøre det.
Har du skrudd på offloading?
Er du sikker på at igmp-proxy går? Den kan stoppe iblant ved feil konfig så du må ta en igmp-proxy restart.
Konfig?
Sist endret av guleman; 1 uke siden kl. 20:31.